{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:authorize-project. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-52552 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:authorize-project to 1.8.0 or later.","what":"CVE-2024-52552 is a high-severity cross-site scripting vulnerability in Jenkins Authorize Project Plugin, published on 13 Nov 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-52552 and fix it if it is affected.\n\nWhat it is: CVE-2024-52552 is a high-severity cross-site scripting vulnerability in Jenkins Authorize Project Plugin, published on 13 Nov 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-52552 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:authorize-project (Maven): affected all versions; fixed in 1.8.0\n- org.jenkins-ci.plugins:authorize-project (Maven): affected all versions; fixed in 1.8.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-52552/ (Markdown: https://insights.sbomify.com/CVE-2024-52552/index.md)","id":"CVE-2024-52552","markdown":"https://insights.sbomify.com/CVE-2024-52552/index.md","name":"CVE-2024-52552","record":{"aliases":["GHSA-8886-8v27-85j8"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins Authorize Project Plugin","requires_auth":"low_privilege","summary":"Attackers with Item/Configure permission can inject JavaScript into job names, leading to stored XSS in the Jenkins Authorize Project Plugin.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"authorize_project","vendor":"jenkins"}],"cvss":{"score":8,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Jenkins Authorize Project Plugin 1.7.2 and earlier evaluates a string containing the job name with JavaScript on the Authorization view, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Stored XSS vulnerability in Jenkins Authorize Project Plugin","id":"CVE-2024-52552","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2024"},"n_packages":2,"n_references":1,"next":{"headline":"Session fixation vulnerability in Jenkins OpenId Connect Authentication Plugin","id":"CVE-2024-52553"},"packages":[{"ecosystem":"Maven","fixed":["1.8.0"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:authorize-project","purl":null,"source":"GHSA-8886-8v27-85j8"},{"ecosystem":"Maven","fixed":["1.8.0"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:authorize-project","purl":"pkg:maven/org.jenkins-ci.plugins/authorize-project","source":"GHSA-8886-8v27-85j8"}],"prev":{"headline":"Restarting a run with revoked script approval allowed by Jenkins Pipeline: Declarative Plugin","id":"CVE-2024-52551"},"products":["Jenkins Authorize Project Plugin"],"published":"2024-11-13","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-11-14","vendors":["Jenkins Project"]},"summary":"Attackers with Item/Configure permission can inject JavaScript into job names, leading to stored XSS in the Jenkins Authorize Project Plugin.","url":"https://insights.sbomify.com/CVE-2024-52552/"}