# CVE-2024-5257: Improper Access Control in GitLab

> A Developer user with a specific custom role can improperly modify the URL for a group namespace, requiring access control fixes.

- **Severity:** Medium 4.9 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Jul 2024
- **Updated:** 29 Aug 2024
- **Also known as:** BIT-gitlab-2024-5257, GHSA-c5g3-c7f9-3hcj, UBUNTU-CVE-2024-5257

## What is CVE-2024-5257?

CVE-2024-5257 is a medium-severity missing authorization vulnerability in Gitlab Gitlab, published on 11 Jul 2024. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

An issue was discovered in GitLab CE/EE affecting all versions starting from 17.0 prior to 17.0.4 and from 17.1 prior to 17.1.2 where a Developer user with `admin_compliance_framework` custom role may have been able to modify the URL for a group namespace.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2024-5257?

1 open source package ship an affected version, including gitlab. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gitlab` | Bitnami | From 17.0.0 | 17.0.4, 17.1.2 |

Products: Gitlab Gitlab.

## How do I fix CVE-2024-5257?

Upgrade gitlab to a fixed version for your release line: 17.0.4 or 17.1.2.

## Is CVE-2024-5257 being exploited?

There is no known exploitation of CVE-2024-5257 in the wild and no public exploit code.

## Other vulnerabilities in Gitlab Gitlab

- [CVE-2026-97229](https://insights.sbomify.com/CVE-2026-97229/): GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound (critical 10.0, exploited in the wild)
- [CVE-2026-85706](https://insights.sbomify.com/CVE-2026-85706/): GitLab Community Edition and Enterprise Edition Path Traversal (critical 10.0, exploited in the wild)
- [CVE-2023-7028](https://insights.sbomify.com/CVE-2023-7028/): GitLab Community and Enterprise Editions Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2021-22205](https://insights.sbomify.com/CVE-2021-22205/): GitLab Community and Enterprise Editions Remote Code Execution (critical 10.0, exploited in the wild)
- [CVE-2021-39935](https://insights.sbomify.com/CVE-2021-39935/): GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF) (medium 6.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-5257 and fix it if it is affected.

What it is: CVE-2024-5257 is a medium-severity missing authorization vulnerability in Gitlab Gitlab, published on 11 Jul 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-5257 in the wild and no public exploit code.

Affected packages and fixed versions:
- gitlab (Bitnami): affected from 17.0.0; fixed in 17.0.4, 17.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-5257/ (Markdown: https://insights.sbomify.com/CVE-2024-5257/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-5257
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-5257
- OSV: https://osv.dev/vulnerability/CVE-2024-5257

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-5257/
Summaries are generated and may contain mistakes; the official description above is the record.
