# CVE-2024-52586: eLabFTW MFA bypass


- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 9 Dec 2024
- **Updated:** 10 Dec 2024
- **Also known as:** GHSA-pvxr-39g3-m28c

## What is CVE-2024-52586?

CVE-2024-52586 is a medium-severity vulnerability in elabftw, published on 9 Dec 2024. 

### Official description

eLabFTW is an open source electronic lab notebook for research labs. A vulnerability has been found starting in version 4.6.0 and prior to version 5.1.0 that allows an attacker to bypass eLabFTW's built-in multifactor authentication mechanism. An attacker who can authenticate locally (by knowing or guessing the password of a user) can thus log in regardless of MFA requirements. This does not affect MFA that are performed by single sign-on services. Users are advised to upgrade to at least version 5.1.9 to receive a fix.

Weakness: CWE-303 (Incorrect Implementation of Authentication Algorithm), CWE-288 (Authentication Bypass Using an Alternate Path or Channel)

## Which versions are affected by CVE-2024-52586?

It affects 1 product.


Products: Elabftw Elabftw.

## How do I fix CVE-2024-52586?

No fix has been published for CVE-2024-52586 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-52586 being exploited?

There is no known exploitation of CVE-2024-52586 in the wild and no public exploit code.

## Other vulnerabilities in elabftw

- [CVE-2021-43834](https://insights.sbomify.com/CVE-2021-43834/): Incorrect Authentication in elabftw (critical 9.1)
- [CVE-2024-28100](https://insights.sbomify.com/CVE-2024-28100/): Stored Cross-site Scripting leading to arbitrary actions taken on behalf of users in elabftw (high 8.9)
- [CVE-2019-12185](https://insights.sbomify.com/CVE-2019-12185/): File upload in n/a (high 8.8)
- [CVE-2024-25632](https://insights.sbomify.com/CVE-2024-25632/): Unauthorised granting of administrator privileges over arbitrary teams under certain circumstances (high 8.6)
- [CVE-2025-25206](https://insights.sbomify.com/CVE-2025-25206/): Incorrect input validation could allow an authenticated user to read sensitive information (high 8.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-52586 and fix it if it is affected.

What it is: CVE-2024-52586 is a medium-severity vulnerability in elabftw, published on 9 Dec 2024. 
Exploitation: There is no known exploitation of CVE-2024-52586 in the wild and no public exploit code.

Affected product: elabftw. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-52586/ (Markdown: https://insights.sbomify.com/CVE-2024-52586/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-52586
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-52586
- OSV: https://osv.dev/vulnerability/CVE-2024-52586

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-52586/
Summaries are generated and may contain mistakes; the official description above is the record.
