# CVE-2024-52588: Strapi allows Server-Side Request Forgery in Webhook function

> Attackers can exploit a Server-Side Request Forgery vulnerability in Strapi's Webhook function to force the application to fetch internal resources.

- **Severity:** Medium 4.9 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 May 2025
- **Updated:** 29 May 2025
- **Also known as:** GHSA-v8wj-f5c7-pvxf

## What is CVE-2024-52588?

CVE-2024-52588 is a medium-severity server-side request forgery vulnerability in strapi, published on 29 May 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Strapi is an open-source content management system. Prior to version 4.25.2, inputting a local domain into the Webhooks URL field leads to the application fetching itself, resulting in a server side request forgery (SSRF). This issue has been patched in version 4.25.2.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2024-52588?

2 open source packages ship an affected version, including @strapi/admin. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@strapi/admin` | npm | All versions | 4.25.2 |
| `@strapi/admin` | npm | All versions | 4.25.2 |

Products: Strapi Strapi.

## How do I fix CVE-2024-52588?

Upgrade @strapi/admin to 4.25.2 or later.

## Is CVE-2024-52588 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-52588 exists.

## Other vulnerabilities in strapi

- [CVE-2023-22894](https://insights.sbomify.com/CVE-2023-22894/): Strapi Cleartext Storage of Sensitive Information (high 7.2, exploited in the wild)
- [CVE-2023-22621](https://insights.sbomify.com/CVE-2023-22621/): Strapi plugins vulnerable to Server-Side Template Injection and Remote Code Execution in the Users-Permissions Plugin (critical 10.0)
- [CVE-2022-27263](https://insights.sbomify.com/CVE-2022-27263/): Unrestricted Upload of File with Dangerous Type in Strapi (critical 9.8)
- [CVE-2020-27664](https://insights.sbomify.com/CVE-2020-27664/): Authorization bypass in Strapi (critical 9.8)
- [CVE-2019-18818](https://insights.sbomify.com/CVE-2019-18818/): Strapi allows unauthenticated attacker to reset admin password without valid reset token (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-52588 and fix it if it is affected.

What it is: CVE-2024-52588 is a medium-severity server-side request forgery vulnerability in strapi, published on 29 May 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-52588 exists.

Affected packages and fixed versions:
- @strapi/admin (npm): affected all versions; fixed in 4.25.2
- @strapi/admin (npm): affected all versions; fixed in 4.25.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-52588/ (Markdown: https://insights.sbomify.com/CVE-2024-52588/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-52588
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-52588
- OSV: https://osv.dev/vulnerability/CVE-2024-52588

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-52588/
Summaries are generated and may contain mistakes; the official description above is the record.
