# CVE-2024-52595: HTML Cleaner allows crafted scripts in special contexts like svg or math to pass through

> Attackers can inject malicious scripts via special HTML tags like svg or math, bypassing sanitization and executing code in victim browsers.

- **Severity:** High 7.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Nov 2024
- **Updated:** 20 Nov 2024
- **Also known as:** DEBIAN-CVE-2024-52595, GHSA-5jfw-gq64-q45f, PYSEC-2024-160, UBUNTU-CVE-2024-52595

## What is CVE-2024-52595?

CVE-2024-52595 is a high-severity cross-site scripting vulnerability in fedora-python lxml_html_clean, published on 19 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

lxml_html_clean is a project for HTML cleaning functionalities copied from `lxml.html.clean`. Prior to version 0.4.0, the HTML Parser in lxml does not properly handle context-switching for special HTML tags such as `<svg>`, `<math>` and `<noscript>`. This behavior deviates from how web browsers parse and interpret such tags. Specifically, content in CSS comments is ignored by lxml_html_clean but may be interpreted differently by web browsers, enabling malicious scripts to bypass the cleaning process. This vulnerability could lead to Cross-Site Scripting (XSS) attacks, compromising the security of users relying on lxml_html_clean in default configuration for sanitizing untrusted HTML content. Users employing the HTML cleaner in a security-sensitive context should upgrade to lxml 0.4.0, which addresses this issue. As a temporary mitigation, users can configure lxml_html_clean with the following settings to prevent the exploitation of this vulnerability. Via `remove_tags`, one may specify tags to remove - their content is moved to their parents' tags. Via `kill_tags`, one may specify tags to be removed completely. Via `allow_tags`, one may restrict the set of permissible tags, excluding context-switching tags like `<svg>`, `<math>` and `<noscript>`.

Weakness: CWE-83 (Improper Neutralization of Script in Attributes in a Web Page), CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-184 (Incomplete List of Disallowed Inputs)

## Which versions are affected by CVE-2024-52595?

3 open source packages ship an affected version, including lxml-html-clean. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `lxml-html-clean` | PyPI | All versions | 0.4.0 |
| `lxml-html-clean` | PyPI | All versions | 0.4.0 |
| `lxml-html-clean` | PyPI | All versions | 0.4.0 |

Products: Fedoralovespython Lxml Html Clean.

## How do I fix CVE-2024-52595?

Upgrade lxml-html-clean to 0.4.0 or later.

## Is CVE-2024-52595 being exploited?

There is no known exploitation of CVE-2024-52595 in the wild and no public exploit code.

## Other vulnerabilities in fedora-python lxml_html_clean

- [CVE-2026-28348](https://insights.sbomify.com/CVE-2026-28348/): lxml_html_clean: CSS @import Filter Bypass via Unicode Escapes (medium 6.1)
- [CVE-2026-28350](https://insights.sbomify.com/CVE-2026-28350/): lxml_html_clean: <base> tag injection through default Cleaner configuration (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-52595 and fix it if it is affected.

What it is: CVE-2024-52595 is a high-severity cross-site scripting vulnerability in fedora-python lxml_html_clean, published on 19 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-52595 in the wild and no public exploit code.

Affected packages and fixed versions:
- lxml-html-clean (PyPI): affected all versions; fixed in 0.4.0
- lxml-html-clean (PyPI): affected all versions; fixed in 0.4.0
- lxml-html-clean (PyPI): affected all versions; fixed in 0.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-52595/ (Markdown: https://insights.sbomify.com/CVE-2024-52595/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-52595
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-52595
- OSV: https://osv.dev/vulnerability/CVE-2024-52595

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-52595/
Summaries are generated and may contain mistakes; the official description above is the record.
