CVE-2024-52596 SimpleSAMLphp xml-common XXE vulnerability

High 8.8 Published Updated

Attackers can exploit an XML External Entity vulnerability in SimpleSAMLphp's xml-common library to read sensitive files or cause denial of service.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-52596?

CVE-2024-52596 is a high-severity vulnerability in simplesamlphp xml-common, published on 2 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

SimpleSAMLphp xml-common is a common classes for handling XML-structures. When loading an (untrusted) XML document, for example the SAMLResponse, it's possible to induce an XXE. This vulnerability is fixed in 1.19.0.

Weakness: CWE-611

Which versions are affected by CVE-2024-52596?

2 open source packages ship an affected version, including simplesamlphp/xml-common.

PackageAffectedFixed in
simplesamlphp/xml-common PackagistAll versions1.20.0
simplesamlphp/xml-common PackagistAll versions1.20.0

How do I fix CVE-2024-52596?

Upgrade simplesamlphp/xml-common to 1.20.0 or later.

Is CVE-2024-52596 being exploited?

There is no known exploitation of CVE-2024-52596 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2024-52596, GHSA-2x65-fpch-2fcm, UBUNTU-CVE-2024-52596.

Is CVE-2024-52596 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free