# CVE-2024-52596: SimpleSAMLphp xml-common XXE vulnerability

> Attackers can exploit an XML External Entity vulnerability in SimpleSAMLphp's xml-common library to read sensitive files or cause denial of service.

- **Severity:** High 8.8 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:H/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Dec 2024
- **Updated:** 2 Dec 2024
- **Also known as:** DEBIAN-CVE-2024-52596, GHSA-2x65-fpch-2fcm, UBUNTU-CVE-2024-52596

## What is CVE-2024-52596?

CVE-2024-52596 is a high-severity vulnerability in simplesamlphp xml-common, published on 2 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

SimpleSAMLphp xml-common is a common classes for handling XML-structures. When loading an (untrusted) XML document, for example the SAMLResponse, it's possible to induce an XXE. This vulnerability is fixed in 1.19.0.

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2024-52596?

2 open source packages ship an affected version, including simplesamlphp/xml-common.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `simplesamlphp/xml-common` | Packagist | All versions | 1.20.0 |
| `simplesamlphp/xml-common` | Packagist | All versions | 1.20.0 |

## How do I fix CVE-2024-52596?

Upgrade simplesamlphp/xml-common to 1.20.0 or later.

## Is CVE-2024-52596 being exploited?

There is no known exploitation of CVE-2024-52596 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-52596 and fix it if it is affected.

What it is: CVE-2024-52596 is a high-severity vulnerability in simplesamlphp xml-common, published on 2 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-52596 in the wild and no public exploit code.

Affected packages and fixed versions:
- simplesamlphp/xml-common (Packagist): affected all versions; fixed in 1.20.0
- simplesamlphp/xml-common (Packagist): affected all versions; fixed in 1.20.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-52596/ (Markdown: https://insights.sbomify.com/CVE-2024-52596/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-52596
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-52596
- OSV: https://osv.dev/vulnerability/CVE-2024-52596

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-52596/
Summaries are generated and may contain mistakes; the official description above is the record.
