# CVE-2024-52600: Statamic CMS has Path Traversal in Asset Upload

> Attackers with upload permissions can use crafted filenames to place assets in unintended server locations, potentially overriding existing files.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Nov 2024
- **Updated:** 3 Dec 2024
- **Also known as:** GHSA-p7f6-8mcm-fwv3

## What is CVE-2024-52600?

CVE-2024-52600 is a medium-severity path traversal vulnerability in statamic cms, published on 19 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Statmatic is a Laravel and Git powered content management system (CMS). Prior to version 5.17.0, assets uploaded with appropriately crafted filenames may result in them being placed in a location different than what was configured. The issue affects front-end forms with `assets` fields and other places where assets can be uploaded, although users would need upload permissions anyway. Files can be uploaded so they would be located on the server in a different location, and potentially override existing files. Traversal outside an asset container is not possible. This path traversal vulnerability has been fixed in 5.17.0.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2024-52600?

2 open source packages ship an affected version, including statamic/cms.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `statamic/cms` | Packagist | All versions | 5.17.0 |
| `statamic/cms` | Packagist | All versions | 5.17.0 |

## How do I fix CVE-2024-52600?

Upgrade statamic/cms to 5.17.0 or later.

## Is CVE-2024-52600 being exploited?

There is no known exploitation of CVE-2024-52600 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-52600 and fix it if it is affected.

What it is: CVE-2024-52600 is a medium-severity path traversal vulnerability in statamic cms, published on 19 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-52600 in the wild and no public exploit code.

Affected packages and fixed versions:
- statamic/cms (Packagist): affected all versions; fixed in 5.17.0
- statamic/cms (Packagist): affected all versions; fixed in 5.17.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-52600/ (Markdown: https://insights.sbomify.com/CVE-2024-52600/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-52600
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-52600
- OSV: https://osv.dev/vulnerability/CVE-2024-52600

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-52600/
Summaries are generated and may contain mistakes; the official description above is the record.
