{"answers":{"affected":"2 open source packages ship an affected version, including pwpush.","exploited":"There is no known exploitation of CVE-2024-52796 in the wild and no public exploit code.","fix":"Upgrade pwpush to 1.49.0 or later.","what":"CVE-2024-52796 is a medium-severity vulnerability in pglombardo PasswordPusher, published on 20 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-52796 and fix it if it is affected.\n\nWhat it is: CVE-2024-52796 is a medium-severity vulnerability in pglombardo PasswordPusher, published on 20 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-52796 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pwpush (RubyGems): affected all versions; fixed in 1.49.0\n- pwpush (RubyGems): affected all versions; fixed in 1.49.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-52796/ (Markdown: https://insights.sbomify.com/CVE-2024-52796/index.md)","id":"CVE-2024-52796","markdown":"https://insights.sbomify.com/CVE-2024-52796/index.md","name":"CVE-2024-52796","record":{"aliases":["GHSA-ffp2-8p2h-4m5j"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Password Pusher","requires_auth":"none","summary":"Attackers can bypass rate limiting by forging proxy headers, enabling unlimited traffic and potential denial of service against Password Pusher instances.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-770","name":"Allocation of Resources Without Limits or Throttling"}],"description":"Password Pusher, an open source application to communicate sensitive information over the web, comes with a configurable rate limiter.  In versions prior to v1.49.0, the rate limiter could be bypassed by forging proxy headers allowing bad actors to send unlimited traffic to the site potentially causing a denial of service. In v1.49.0, a fix was implemented to only authorize proxies on local IPs which resolves this issue. As a workaround, one may add rules to one's proxy and/or firewall to not accept external proxy headers such as `X-Forwarded-*` from clients.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Password Pusher's rate limiter can be bypassed by forging proxy headers","id":"CVE-2024-52796","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"security_feature_bypass","year":"2024"},"n_packages":2,"n_references":3,"next":{"headline":"Searching Opencast may cause a denial of service","id":"CVE-2024-52797"},"packages":[{"ecosystem":"RubyGems","fixed":["1.49.0"],"introduced":["0"],"last_affected":[],"package":"pwpush","purl":null,"source":"GHSA-ffp2-8p2h-4m5j"},{"ecosystem":"RubyGems","fixed":["1.49.0"],"introduced":["0"],"last_affected":[],"package":"pwpush","purl":"pkg:gem/pwpush","source":"GHSA-ffp2-8p2h-4m5j"}],"prev":{"headline":"Magnific lightbox susceptible to Cross-site Scripting in Discourse","id":"CVE-2024-52794"},"products":["PasswordPusher"],"published":"2024-11-20","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-11-20","vendors":["pglombardo"]},"summary":"Attackers can bypass rate limiting by forging proxy headers, enabling unlimited traffic and potential denial of service against Password Pusher instances.","url":"https://insights.sbomify.com/CVE-2024-52796/"}