# CVE-2024-52796: Password Pusher's rate limiter can be bypassed by forging proxy headers

> Attackers can bypass rate limiting by forging proxy headers, enabling unlimited traffic and potential denial of service against Password Pusher instances.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Nov 2024
- **Updated:** 20 Nov 2024
- **Also known as:** GHSA-ffp2-8p2h-4m5j

## What is CVE-2024-52796?

CVE-2024-52796 is a medium-severity vulnerability in pglombardo PasswordPusher, published on 20 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Password Pusher, an open source application to communicate sensitive information over the web, comes with a configurable rate limiter.  In versions prior to v1.49.0, the rate limiter could be bypassed by forging proxy headers allowing bad actors to send unlimited traffic to the site potentially causing a denial of service. In v1.49.0, a fix was implemented to only authorize proxies on local IPs which resolves this issue. As a workaround, one may add rules to one's proxy and/or firewall to not accept external proxy headers such as `X-Forwarded-*` from clients.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2024-52796?

2 open source packages ship an affected version, including pwpush.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pwpush` | RubyGems | All versions | 1.49.0 |
| `pwpush` | RubyGems | All versions | 1.49.0 |

## How do I fix CVE-2024-52796?

Upgrade pwpush to 1.49.0 or later.

## Is CVE-2024-52796 being exploited?

There is no known exploitation of CVE-2024-52796 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-52796 and fix it if it is affected.

What it is: CVE-2024-52796 is a medium-severity vulnerability in pglombardo PasswordPusher, published on 20 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-52796 in the wild and no public exploit code.

Affected packages and fixed versions:
- pwpush (RubyGems): affected all versions; fixed in 1.49.0
- pwpush (RubyGems): affected all versions; fixed in 1.49.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-52796/ (Markdown: https://insights.sbomify.com/CVE-2024-52796/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-52796
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-52796
- OSV: https://osv.dev/vulnerability/CVE-2024-52796

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-52796/
Summaries are generated and may contain mistakes; the official description above is the record.
