# CVE-2024-52797: Searching Opencast may cause a denial of service

> Attackers with admin or API view roles can trigger infinite retry loops via invalid search queries, causing disk exhaustion and denial of service.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Nov 2024
- **Updated:** 28 Oct 2025
- **Also known as:** GHSA-jh6x-7xfg-9cq2

## What is CVE-2024-52797?

CVE-2024-52797 is a medium-severity denial of service vulnerability in opencast, published on 21 Nov 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Opencast is free and open source software for automated video capture and distribution. First noticed in Opencast 13 and 14, Opencast's Elasticsearch integration may generate syntactically invalid Elasticsearch queries in relation to previously acceptable search queries. From Opencast version 11.4 and newer, Elasticsearch queries are retried a configurable number of times in the case of error to handle temporary losses of connection to Elasticsearch. These invalid queries would fail, causing the retry mechanism to begin requerying with the same syntactically invalid query immediately, in an infinite loop. This causes a massive increase in log size which can in some cases cause a denial of service due to disk exhaustion.

Opencast 13.10 and Opencast 14.3 contain patches which address the base issue, with Opencast 16.7 containing changes which harmonize the search behaviour between the admin UI and external API. Users are strongly recommended to upgrade as soon as possible if running versions prior to 13.10 or 14.3. While the relevant endpoints require (by default) `ROLE_ADMIN` or `ROLE_API_SERIES_VIEW`, the problem queries are otherwise innocuous. This issue could be easily triggered by normal administrative work on an affected Opencast system. Those who run a version newer than 13.10 and 14.3 and see different results when searching in their admin UI vs your external API or LMS, may resolve the issue by upgrading to 16.7. No known workarounds for the vulnerability are available.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2024-52797?

6 open source packages ship an affected version, including org.opencastproject:opencast-elasticsearch-impl. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.opencastproject:opencast-elasticsearch-impl` | Maven | From 11.4 | 13.10 |
| `org.opencastproject:opencast-elasticsearch-impl` | Maven | From 11.4 | 13.10 |
| `org.opencastproject:opencast-elasticsearch-impl` | Maven | From 14.0 | 14.3 |
| `org.opencastproject:opencast-elasticsearch-impl` | Maven | From 14.0 | 14.3 |
| `org.opencastproject:opencast-elasticsearch-impl` | Maven | From 15.0 | 16.7 |
| `org.opencastproject:opencast-elasticsearch-impl` | Maven | From 15.0 | 16.7 |

Products: Apereo Opencast.

## How do I fix CVE-2024-52797?

Upgrade org.opencastproject:opencast-elasticsearch-impl to a fixed version for your release line: 13.10, 14.3 or 16.7.

## Is CVE-2024-52797 being exploited?

There is no known exploitation of CVE-2024-52797 in the wild and no public exploit code.

## Other vulnerabilities in opencast

- [CVE-2021-43821](https://insights.sbomify.com/CVE-2021-43821/): Files Accessible to External Parties in Opencast (critical 9.9)
- [CVE-2020-5206](https://insights.sbomify.com/CVE-2020-5206/): Authentication Bypass For Endpoints With Anonymous Access in OpenCast (high 8.7)
- [CVE-2021-32623](https://insights.sbomify.com/CVE-2021-32623/): Opencast vulnerable to billion laughs attack (XML bomb) (high 8.1)
- [CVE-2020-5229](https://insights.sbomify.com/CVE-2020-5229/): Opencast stores passwords using outdated MD5 hash algorithm (high 7.7)
- [CVE-2020-5230](https://insights.sbomify.com/CVE-2020-5230/): Opencast uses unsafe identifiers (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-52797 and fix it if it is affected.

What it is: CVE-2024-52797 is a medium-severity denial of service vulnerability in opencast, published on 21 Nov 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-52797 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.opencastproject:opencast-elasticsearch-impl (Maven): affected from 11.4; fixed in 13.10
- org.opencastproject:opencast-elasticsearch-impl (Maven): affected from 11.4; fixed in 13.10
- org.opencastproject:opencast-elasticsearch-impl (Maven): affected from 14.0; fixed in 14.3
- org.opencastproject:opencast-elasticsearch-impl (Maven): affected from 14.0; fixed in 14.3
- org.opencastproject:opencast-elasticsearch-impl (Maven): affected from 15.0; fixed in 16.7
- org.opencastproject:opencast-elasticsearch-impl (Maven): affected from 15.0; fixed in 16.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-52797/ (Markdown: https://insights.sbomify.com/CVE-2024-52797/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-52797
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-52797
- OSV: https://osv.dev/vulnerability/CVE-2024-52797

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-52797/
Summaries are generated and may contain mistakes; the official description above is the record.
