# CVE-2024-52798: path-to-regexp Unpatched `path-to-regexp` ReDoS in 0.1.x

> Attackers can cause denial of service via ReDoS in path-to-regexp by providing malicious path strings that trigger excessive backtracking.

- **Severity:** High 7.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Dec 2024
- **Updated:** 24 Jan 2025
- **Also known as:** AZL-54017, AZL-54020, AZL-54036, CLEANSTART-2026-BK66130, CLEANSTART-2026-ZQ97544, CLSA-2026-1790520007, ECHO-8ffe-c246-e62c, GHSA-rhx6-c78j-4q9w, MINI-7x3p-c79f-r6j4, MINI-m4gw-jqhq-2qg2, ROOT-APP-NPM-CVE-2024-52798

## What is CVE-2024-52798?

CVE-2024-52798 is a high-severity denial of service vulnerability in pillarjs path-to-regexp, published on 5 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

path-to-regexp turns path strings into a regular expressions. In certain cases, path-to-regexp will output a regular expression that can be exploited to cause poor performance. The regular expression that is vulnerable to backtracking can be generated in the 0.1.x release of path-to-regexp. Upgrade to 0.1.12. This vulnerability exists because of an incomplete fix for CVE-2024-45296.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2024-52798?

2 open source packages ship an affected version, including path-to-regexp.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `path-to-regexp` | npm | All versions | 0.1.12 |
| `path-to-regexp` | npm | All versions | 0.1.12 |

## How do I fix CVE-2024-52798?

Upgrade path-to-regexp to 0.1.12 or later.

## Is CVE-2024-52798 being exploited?

There is no known exploitation of CVE-2024-52798 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-52798 and fix it if it is affected.

What it is: CVE-2024-52798 is a high-severity denial of service vulnerability in pillarjs path-to-regexp, published on 5 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-52798 in the wild and no public exploit code.

Affected packages and fixed versions:
- path-to-regexp (npm): affected all versions; fixed in 0.1.12
- path-to-regexp (npm): affected all versions; fixed in 0.1.12

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-52798/ (Markdown: https://insights.sbomify.com/CVE-2024-52798/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-52798
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-52798
- OSV: https://osv.dev/vulnerability/CVE-2024-52798

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-52798/
Summaries are generated and may contain mistakes; the official description above is the record.
