{"answers":{"affected":"","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-52799 exists.","fix":"No fix has been published for CVE-2024-52799 yet. Limit exposure of the affected software until one is available.","what":"CVE-2024-52799 is a high-severity vulnerability in argoproj argo-helm, published on 21 Nov 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-52799 and fix it if it is affected.\n\nWhat it is: CVE-2024-52799 is a high-severity vulnerability in argoproj argo-helm, published on 21 Nov 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-52799 exists.\n\nAffected product: argoproj argo-helm. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-52799/ (Markdown: https://insights.sbomify.com/CVE-2024-52799/index.md)","id":"CVE-2024-52799","markdown":"https://insights.sbomify.com/CVE-2024-52799/index.md","name":"CVE-2024-52799","record":{"aliases":["GHSA-fgrf-2886-4q7m"],"analysis":{"component_type":"container_or_infrastructure","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Argo Workflows Helm Chart","requires_auth":"low_privilege","summary":"Excessive privileges in the Argo Workflows Helm Chart allow attackers to execute arbitrary code in any pod within the namespace via kubectl exec.","user_interaction":"required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.3,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-250","name":"Execution with Unnecessary Privileges"},{"id":"CWE-1220","name":"Insufficient Granularity of Access Control"}],"description":"Argo Workflows Chart is used to set up argo and its needed dependencies through one command. Prior to 0.44.0, the workflow-role has excessive privileges, the worst being create pods/exec, which will allow kubectl exec into any Pod in the same namespace, i.e. arbitrary code execution within those Pods. If a user can be made to run a malicious template, their whole namespace can be compromised. This affects versions of the argo-workflows Chart that use appVersion: 3.4 and above, which no longer need these permissions for the only available Executor, Emissary. It could also affect users below 3.4 depending on their choice of Executor in those versions. This only affects the Helm Chart and not the upstream manifests. This vulnerability is fixed in 0.44.0.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"Argo Workflows Chart: Excessive Privileges in Workflow Role","id":"CVE-2024-52799","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"privilege_escalation","year":"2024"},"n_packages":0,"n_references":2,"next":{"headline":"Potential XXE (XML External Entity Injection) vulnerability in veraPDF CLI","id":"CVE-2024-52800"},"packages":[],"prev":{"headline":"path-to-regexp Unpatched `path-to-regexp` ReDoS in 0.1.x","id":"CVE-2024-52798"},"products":["argo-helm"],"published":"2024-11-21","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-11-21","vendors":["argoproj"]},"summary":"Excessive privileges in the Argo Workflows Helm Chart allow attackers to execute arbitrary code in any pod within the namespace via kubectl exec.","url":"https://insights.sbomify.com/CVE-2024-52799/"}