# CVE-2024-52799: Argo Workflows Chart: Excessive Privileges in Workflow Role

> Excessive privileges in the Argo Workflows Helm Chart allow attackers to execute arbitrary code in any pod within the namespace via kubectl exec.

- **Severity:** High 8.3 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 21 Nov 2024
- **Updated:** 21 Nov 2024
- **Also known as:** GHSA-fgrf-2886-4q7m

## What is CVE-2024-52799?

CVE-2024-52799 is a high-severity vulnerability in argoproj argo-helm, published on 21 Nov 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Argo Workflows Chart is used to set up argo and its needed dependencies through one command. Prior to 0.44.0, the workflow-role has excessive privileges, the worst being create pods/exec, which will allow kubectl exec into any Pod in the same namespace, i.e. arbitrary code execution within those Pods. If a user can be made to run a malicious template, their whole namespace can be compromised. This affects versions of the argo-workflows Chart that use appVersion: 3.4 and above, which no longer need these permissions for the only available Executor, Emissary. It could also affect users below 3.4 depending on their choice of Executor in those versions. This only affects the Helm Chart and not the upstream manifests. This vulnerability is fixed in 0.44.0.

Weakness: CWE-250 (Execution with Unnecessary Privileges), CWE-1220 (Insufficient Granularity of Access Control)

## Which versions are affected by CVE-2024-52799?


## How do I fix CVE-2024-52799?

No fix has been published for CVE-2024-52799 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-52799 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-52799 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-52799 and fix it if it is affected.

What it is: CVE-2024-52799 is a high-severity vulnerability in argoproj argo-helm, published on 21 Nov 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-52799 exists.

Affected product: argoproj argo-helm. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-52799/ (Markdown: https://insights.sbomify.com/CVE-2024-52799/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-52799
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-52799
- OSV: https://osv.dev/vulnerability/CVE-2024-52799

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-52799/
Summaries are generated and may contain mistakes; the official description above is the record.
