# CVE-2024-52805: Synapse allows unsupported content types to lead to memory exhaustion

> Attackers can cause memory exhaustion and denial of service in Synapse via multipart/form-data requests in certain configurations.

- **Severity:** High 8.2 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Dec 2024
- **Updated:** 3 Dec 2024
- **Also known as:** GHSA-rfq8-j7rh-8hf2, PYSEC-2026-1613, UBUNTU-CVE-2024-52805

## What is CVE-2024-52805?

CVE-2024-52805 is a high-severity denial of service vulnerability in element-hq synapse, published on 3 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Synapse is an open-source Matrix homeserver. In Synapse before 1.120.1, multipart/form-data requests can in certain configurations transiently increase memory consumption beyond expected levels while processing the request, which can be used to amplify denial of service attacks. Synapse 1.120.1 resolves the issue by denying requests with unsupported multipart/form-data content type.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2024-52805?

3 open source packages ship an affected version, including matrix-synapse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `matrix-synapse` | PyPI | All versions | 1.120.1 |
| `matrix-synapse` | PyPI | All versions | 1.120.1 |
| `matrix-synapse` | PyPI | All versions | 1.120.1 |

Products: Matrix Synapse.

## How do I fix CVE-2024-52805?

Upgrade matrix-synapse to 1.120.1 or later.

## Is CVE-2024-52805 being exploited?

There is no known exploitation of CVE-2024-52805 in the wild and no public exploit code.

## Other vulnerabilities in element-hq synapse

- [CVE-2019-18835](https://insights.sbomify.com/CVE-2019-18835/): Improper Verification of Cryptographic Signature in matrix-synapse (critical 9.8)
- [CVE-2024-52815](https://insights.sbomify.com/CVE-2024-52815/): Synapse allows a a malformed invite to break the invitee's `/sync` (high 8.7)
- [CVE-2024-53863](https://insights.sbomify.com/CVE-2024-53863/): Synapse can be forced to thumbnail unexpected file formats, invoking external, potentially untrustworthy decoders (high 8.2)
- [CVE-2024-37302](https://insights.sbomify.com/CVE-2024-37302/): Synapse denial of service through media disk space consumption (high 7.5)
- [CVE-2018-12423](https://insights.sbomify.com/CVE-2018-12423/): Matrix Synapse Authorization Error (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-52805 and fix it if it is affected.

What it is: CVE-2024-52805 is a high-severity denial of service vulnerability in element-hq synapse, published on 3 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-52805 in the wild and no public exploit code.

Affected packages and fixed versions:
- matrix-synapse (PyPI): affected all versions; fixed in 1.120.1
- matrix-synapse (PyPI): affected all versions; fixed in 1.120.1
- matrix-synapse (PyPI): affected all versions; fixed in 1.120.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-52805/ (Markdown: https://insights.sbomify.com/CVE-2024-52805/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-52805
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-52805
- OSV: https://osv.dev/vulnerability/CVE-2024-52805

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-52805/
Summaries are generated and may contain mistakes; the official description above is the record.
