CVE-2024-52806 SimpleSAMLphp SAML2 has an XXE in parsing SAML messages

High 8.3 Published Updated

Attackers can exploit XML External Entity vulnerabilities in the SimpleSAMLphp SAML2 library to read sensitive data or cause denial of service.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-52806?

CVE-2024-52806 is a high-severity vulnerability in simplesamlphp saml2, published on 2 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

SimpleSAMLphp SAML2 library is a PHP library for SAML2 related functionality. When loading an (untrusted) XML document, for example the SAMLResponse, it's possible to induce an XXE. This vulnerability is fixed in 4.6.14 and 5.0.0-alpha.18.

Weakness: CWE-611

Which versions are affected by CVE-2024-52806?

4 open source packages ship an affected version, including simplesamlphp/saml2 and simplesamlphp/saml2-legacy.

PackageAffectedFixed in
simplesamlphp/saml2 PackagistAll versions4.6.14
simplesamlphp/saml2 PackagistAll versions4.6.14
simplesamlphp/saml2-legacy PackagistAll versions4.6.14
simplesamlphp/saml2-legacy PackagistAll versions4.6.14

How do I fix CVE-2024-52806?

Upgrade simplesamlphp/saml2 to 4.6.14 or later.

Is CVE-2024-52806 being exploited?

There is no known exploitation of CVE-2024-52806 in the wild and no public exploit code.

Public exploit code: 1 proofs of concept on GitHub.

Sources

Also known as DEBIAN-CVE-2024-52806, GHSA-pxm4-r5ph-q2m2, UBUNTU-CVE-2024-52806.

Is CVE-2024-52806 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free