{"answers":{"affected":"4 open source packages ship an affected version, including simplesamlphp/saml2 and simplesamlphp/saml2-legacy.","exploited":"There is no known exploitation of CVE-2024-52806 in the wild and no public exploit code.","fix":"Upgrade simplesamlphp/saml2 to 4.6.14 or later.","what":"CVE-2024-52806 is a high-severity vulnerability in simplesamlphp saml2, published on 2 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-52806 and fix it if it is affected.\n\nWhat it is: CVE-2024-52806 is a high-severity vulnerability in simplesamlphp saml2, published on 2 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-52806 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- simplesamlphp/saml2 (Packagist): affected all versions; fixed in 4.6.14\n- simplesamlphp/saml2 (Packagist): affected all versions; fixed in 4.6.14\n- simplesamlphp/saml2-legacy (Packagist): affected all versions; fixed in 4.6.14\n- simplesamlphp/saml2-legacy (Packagist): affected all versions; fixed in 4.6.14\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-52806/ (Markdown: https://insights.sbomify.com/CVE-2024-52806/index.md)","id":"CVE-2024-52806","markdown":"https://insights.sbomify.com/CVE-2024-52806/index.md","name":"CVE-2024-52806","record":{"aliases":["DEBIAN-CVE-2024-52806","GHSA-pxm4-r5ph-q2m2","UBUNTU-CVE-2024-52806"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"SAML2 PHP library","requires_auth":"none","summary":"Attackers can exploit XML External Entity vulnerabilities in the SimpleSAMLphp SAML2 library to read sensitive data or cause denial of service.","user_interaction":"not_required","vuln_class":"xxe"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.3,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-611","name":"Improper Restriction of XML External Entity Reference"}],"description":"SimpleSAMLphp SAML2 library is a PHP library for SAML2 related functionality. When loading an (untrusted) XML document, for example the SAMLResponse, it's possible to induce an XXE. This vulnerability is fixed in 4.6.14 and 5.0.0-alpha.18.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":"2026-08-12","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2026-08-12T10:39:38Z","kind":"github_poc","ref":"https://github.com/heartlesseorg-dot/CVE-2024-52806-PoC","stars":0,"title":null}],"tier":"poc_unverified"},"has_fix":true,"headline":"SimpleSAMLphp SAML2 has an XXE in parsing SAML messages","id":"CVE-2024-52806","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xxe","year":"2024"},"n_packages":4,"n_references":2,"next":{"headline":"XXE vulnerability in XSLT parsing in `org.hl7.fhir.publisher`","id":"CVE-2024-52807"},"packages":[{"ecosystem":"Packagist","fixed":["4.6.14"],"introduced":["0"],"last_affected":[],"package":"simplesamlphp/saml2","purl":null,"source":"GHSA-pxm4-r5ph-q2m2"},{"ecosystem":"Packagist","fixed":["4.6.14"],"introduced":["0"],"last_affected":[],"package":"simplesamlphp/saml2","purl":"pkg:composer/simplesamlphp/saml2","source":"GHSA-pxm4-r5ph-q2m2"},{"ecosystem":"Packagist","fixed":["4.6.14"],"introduced":["0"],"last_affected":[],"package":"simplesamlphp/saml2-legacy","purl":null,"source":"GHSA-pxm4-r5ph-q2m2"},{"ecosystem":"Packagist","fixed":["4.6.14"],"introduced":["0"],"last_affected":[],"package":"simplesamlphp/saml2-legacy","purl":"pkg:composer/simplesamlphp/saml2-legacy","source":"GHSA-pxm4-r5ph-q2m2"}],"prev":{"headline":"Synapse allows unsupported content types to lead to memory exhaustion","id":"CVE-2024-52805"},"products":["saml2"],"published":"2024-12-02","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-12-02","vendors":["simplesamlphp"]},"summary":"Attackers can exploit XML External Entity vulnerabilities in the SimpleSAMLphp SAML2 library to read sensitive data or cause denial of service.","url":"https://insights.sbomify.com/CVE-2024-52806/"}