{"answers":{"affected":"4 open source packages ship an affected version, including org.hl7.fhir.publisher:org.hl7.fhir.publisher.cli and org.hl7.fhir.publisher:org.hl7.fhir.publisher.core.","exploited":"There is no known exploitation of CVE-2024-52807 in the wild and no public exploit code.","fix":"Upgrade org.hl7.fhir.publisher:org.hl7.fhir.publisher.cli to 1.7.4 or later.","what":"CVE-2024-52807 is a high-severity vulnerability in HL7 fhir-ig-publisher, published on 24 Jan 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-52807 and fix it if it is affected.\n\nWhat it is: CVE-2024-52807 is a high-severity vulnerability in HL7 fhir-ig-publisher, published on 24 Jan 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-52807 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.hl7.fhir.publisher:org.hl7.fhir.publisher.cli (Maven): affected all versions; fixed in 1.7.4\n- org.hl7.fhir.publisher:org.hl7.fhir.publisher.cli (Maven): affected all versions; fixed in 1.7.4\n- org.hl7.fhir.publisher:org.hl7.fhir.publisher.core (Maven): affected all versions; fixed in 1.7.4\n- org.hl7.fhir.publisher:org.hl7.fhir.publisher.core (Maven): affected all versions; fixed in 1.7.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-52807/ (Markdown: https://insights.sbomify.com/CVE-2024-52807/index.md)","id":"CVE-2024-52807","markdown":"https://insights.sbomify.com/CVE-2024-52807/index.md","name":"CVE-2024-52807","record":{"aliases":["GHSA-8c3x-hq82-gjcm"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"FHIR IG Publisher","requires_auth":"none","summary":"An attacker can read host system data via XML external entity injection in the HL7 FHIR IG Publisher library.","user_interaction":"not_required","vuln_class":"xxe"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.6,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-611","name":"Improper Restriction of XML External Entity Reference"}],"description":"The HL7 FHIR IG publisher is a tool to take a set of inputs and create a standard FHIR IG. Prior to version 1.7.4, XSLT transforms performed by various components are vulnerable to XML external entity injections. A processed XML file with a malicious DTD tag `( ]\u003e` could produce XML containing data from the host system. This impacts use cases where org.hl7.fhir.publisher is being used to within a host where external clients can submit XML. A previous release provided an incomplete solution revealed by new testing. This issue has been patched as of version 1.7.4. No known workarounds are available.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"XXE vulnerability in XSLT parsing in `org.hl7.fhir.publisher`","id":"CVE-2024-52807","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xxe","year":"2024"},"n_packages":4,"n_references":3,"next":{"headline":"Cross-site Scripting vulnerability with prototype pollution in vue-i18n","id":"CVE-2024-52809"},"packages":[{"ecosystem":"Maven","fixed":["1.7.4"],"introduced":["0"],"last_affected":[],"package":"org.hl7.fhir.publisher:org.hl7.fhir.publisher.cli","purl":null,"source":"GHSA-8c3x-hq82-gjcm"},{"ecosystem":"Maven","fixed":["1.7.4"],"introduced":["0"],"last_affected":[],"package":"org.hl7.fhir.publisher:org.hl7.fhir.publisher.cli","purl":"pkg:maven/org.hl7.fhir.publisher/org.hl7.fhir.publisher.cli","source":"GHSA-8c3x-hq82-gjcm"},{"ecosystem":"Maven","fixed":["1.7.4"],"introduced":["0"],"last_affected":[],"package":"org.hl7.fhir.publisher:org.hl7.fhir.publisher.core","purl":null,"source":"GHSA-8c3x-hq82-gjcm"},{"ecosystem":"Maven","fixed":["1.7.4"],"introduced":["0"],"last_affected":[],"package":"org.hl7.fhir.publisher:org.hl7.fhir.publisher.core","purl":"pkg:maven/org.hl7.fhir.publisher/org.hl7.fhir.publisher.core","source":"GHSA-8c3x-hq82-gjcm"}],"prev":{"headline":"SimpleSAMLphp SAML2 has an XXE in parsing SAML messages","id":"CVE-2024-52806"},"products":["fhir-ig-publisher"],"published":"2025-01-24","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-01-28","vendors":["HL7"]},"summary":"An attacker can read host system data via XML external entity injection in the HL7 FHIR IG Publisher library.","url":"https://insights.sbomify.com/CVE-2024-52807/"}