# CVE-2024-52807: XXE vulnerability in XSLT parsing in `org.hl7.fhir.publisher`

> An attacker can read host system data via XML external entity injection in the HL7 FHIR IG Publisher library.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Jan 2025
- **Updated:** 28 Jan 2026
- **Also known as:** GHSA-8c3x-hq82-gjcm

## What is CVE-2024-52807?

CVE-2024-52807 is a high-severity vulnerability in HL7 fhir-ig-publisher, published on 24 Jan 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The HL7 FHIR IG publisher is a tool to take a set of inputs and create a standard FHIR IG. Prior to version 1.7.4, XSLT transforms performed by various components are vulnerable to XML external entity injections. A processed XML file with a malicious DTD tag `( ]>` could produce XML containing data from the host system. This impacts use cases where org.hl7.fhir.publisher is being used to within a host where external clients can submit XML. A previous release provided an incomplete solution revealed by new testing. This issue has been patched as of version 1.7.4. No known workarounds are available.

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2024-52807?

4 open source packages ship an affected version, including org.hl7.fhir.publisher:org.hl7.fhir.publisher.cli and org.hl7.fhir.publisher:org.hl7.fhir.publisher.core.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.hl7.fhir.publisher:org.hl7.fhir.publisher.cli` | Maven | All versions | 1.7.4 |
| `org.hl7.fhir.publisher:org.hl7.fhir.publisher.cli` | Maven | All versions | 1.7.4 |
| `org.hl7.fhir.publisher:org.hl7.fhir.publisher.core` | Maven | All versions | 1.7.4 |
| `org.hl7.fhir.publisher:org.hl7.fhir.publisher.core` | Maven | All versions | 1.7.4 |

## How do I fix CVE-2024-52807?

Upgrade org.hl7.fhir.publisher:org.hl7.fhir.publisher.cli to 1.7.4 or later.

## Is CVE-2024-52807 being exploited?

There is no known exploitation of CVE-2024-52807 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-52807 and fix it if it is affected.

What it is: CVE-2024-52807 is a high-severity vulnerability in HL7 fhir-ig-publisher, published on 24 Jan 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-52807 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.hl7.fhir.publisher:org.hl7.fhir.publisher.cli (Maven): affected all versions; fixed in 1.7.4
- org.hl7.fhir.publisher:org.hl7.fhir.publisher.cli (Maven): affected all versions; fixed in 1.7.4
- org.hl7.fhir.publisher:org.hl7.fhir.publisher.core (Maven): affected all versions; fixed in 1.7.4
- org.hl7.fhir.publisher:org.hl7.fhir.publisher.core (Maven): affected all versions; fixed in 1.7.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-52807/ (Markdown: https://insights.sbomify.com/CVE-2024-52807/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-52807
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-52807
- OSV: https://osv.dev/vulnerability/CVE-2024-52807

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-52807/
Summaries are generated and may contain mistakes; the official description above is the record.
