CVE-2024-52810 Prototype Pollution in @intlify/shared >=9.7.0 <= 10.0.4
- Exploited in the wild
- Not known
- Fix
- Available
What is CVE-2024-52810?
CVE-2024-52810 is a medium-severity vulnerability in intlify vue-i18n, published on 29 Nov 2024.
Official description
@intlify/shared is a shared library for the intlify project. The latest version of @intlify/shared (10.0.4) is vulnerable to Prototype Pollution through the entry function(s) lib.deepCopy. An attacker can supply a payload with Object.prototype setter to introduce or modify properties within the global prototype chain, causing denial of service (DoS) as the minimum consequence. Moreover, the consequences of this vulnerability can escalate to other injection-based attacks, depending on how the library integrates within the application. For instance, if the polluted property propagates to sensitive Node.js APIs (e.g., exec, eval), it could enable an attacker to execute arbitrary commands within the application's context. This issue has been addressed in versions 9.14.2, and 10.0.5. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Weakness: CWE-1321
Which versions are affected by CVE-2024-52810?
14 open source packages ship an affected version, including @intlify/vue-i18n-core, @intlify/shared and petite-vue-i18n.
| Package | Affected | Fixed in |
|---|---|---|
@intlify/vue-i18n-core npm | From 10.0.0 | 10.0.5 |
@intlify/vue-i18n-core npm | From 10.0.0 | 10.0.5 |
@intlify/vue-i18n-core npm | From 9.7.0 | 9.14.2 |
@intlify/vue-i18n-core npm | From 9.7.0 | 9.14.2 |
@intlify/shared npm | From 10.0.0 | 10.0.5 |
@intlify/shared npm | From 10.0.0 | 10.0.5 |
8 more packages
@intlify/shared npm | From 9.7.0 | 9.14.2 |
@intlify/shared npm | From 9.7.0 | 9.14.2 |
petite-vue-i18n npm | From 10.0.0 | 10.0.5 |
petite-vue-i18n npm | From 10.0.0 | 10.0.5 |
vue-i18n npm | From 10.0.0 | 10.0.5 |
vue-i18n npm | From 10.0.0 | 10.0.5 |
vue-i18n npm | From 9.7.0 | 9.14.2 |
vue-i18n npm | From 9.7.0 | 9.14.2 |
How do I fix CVE-2024-52810?
Upgrade @intlify/vue-i18n-core to a fixed version for your release line: 10.0.5 or 9.14.2.
Is CVE-2024-52810 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-52810 exists.
Sources
Also known as GHSA-hjwq-mjwj-4x6c.