{"answers":{"affected":"3 open source packages ship an affected version, including matrix-sdk-crypto.","exploited":"There is no known exploitation of CVE-2024-52813 in the wild and no public exploit code.","fix":"Upgrade matrix-sdk-crypto to 0.8.0 or later.","what":"CVE-2024-52813 is a medium-severity vulnerability in matrix-org matrix-rust-sdk, published on 7 Jan 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-52813 and fix it if it is affected.\n\nWhat it is: CVE-2024-52813 is a medium-severity vulnerability in matrix-org matrix-rust-sdk, published on 7 Jan 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-52813 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- matrix-sdk-crypto (crates.io): affected all versions; fixed in 0.8.0\n- matrix-sdk-crypto (crates.io): affected all versions; fixed in 0.8.0\n- matrix-sdk-crypto (crates.io): affected from 0.0.0-0; fixed in 0.8.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-52813/ (Markdown: https://insights.sbomify.com/CVE-2024-52813/index.md)","id":"CVE-2024-52813","markdown":"https://insights.sbomify.com/CVE-2024-52813/index.md","name":"CVE-2024-52813","record":{"aliases":["GHSA-r5vf-wf4h-82gg","RUSTSEC-2024-0434","openSUSE-SU-2025:14726-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Matrix Rust SDK","requires_auth":"low_privilege","summary":"The matrix-sdk-crypto library fails to notify clients when a verified identity becomes unverified, allowing attackers to bypass security warnings.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":4.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-223","name":"Omission of Security-relevant Information"}],"description":"matrix-rust-sdk is an implementation of a Matrix client-server library in Rust. Versions of the matrix-sdk-crypto Rust crate before 0.8.0 lack a dedicated mechanism to notify that a user's cryptographic identity has changed from a verified to an unverified one, which could cause client applications relying on the SDK to overlook such changes. matrix-sdk-crypto 0.8.0 adds a new VerificationLevel::VerificationViolation enum variant which indicates that a previously verified identity has been changed.","ecosystems":["crates.io","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"matrix-sdk-crypto missing facility to signal rotation of a verified cryptographic identity","id":"CVE-2024-52813","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"security_feature_bypass","year":"2024"},"n_packages":4,"n_references":2,"next":{"headline":"Helm Lacks Granularity in Workflow Role","id":"CVE-2024-52814"},"packages":[{"ecosystem":"crates.io","fixed":["0.8.0"],"introduced":["0"],"last_affected":[],"package":"matrix-sdk-crypto","purl":null,"source":"GHSA-r5vf-wf4h-82gg"},{"ecosystem":"crates.io","fixed":["0.8.0"],"introduced":["0"],"last_affected":[],"package":"matrix-sdk-crypto","purl":"pkg:cargo/matrix-sdk-crypto","source":"GHSA-r5vf-wf4h-82gg"},{"ecosystem":"crates.io","fixed":["0.8.0"],"introduced":["0.0.0-0"],"last_affected":[],"package":"matrix-sdk-crypto","purl":"pkg:cargo/matrix-sdk-crypto","source":"RUSTSEC-2024-0434"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["20250204-1.1"],"introduced":["0"],"last_affected":[],"package":"cargo-audit-advisory-db","purl":"pkg:rpm/opensuse/cargo-audit-advisory-db\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2025:14726-1"}],"prev":{"headline":"LF Edge eKuiper has Stored XSS in Rules Functionality","id":"CVE-2024-52812"},"products":["matrix-rust-sdk"],"published":"2025-01-07","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"open","licence":"CC0 1.0","name":"RustSec","prefix":"RUSTSEC"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-01-07","vendors":["matrix-org"]},"summary":"The matrix-sdk-crypto library fails to notify clients when a verified identity becomes unverified, allowing attackers to bypass security warnings.","url":"https://insights.sbomify.com/CVE-2024-52813/"}