# CVE-2024-52813: matrix-sdk-crypto missing facility to signal rotation of a verified cryptographic identity

> The matrix-sdk-crypto library fails to notify clients when a verified identity becomes unverified, allowing attackers to bypass security warnings.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Jan 2025
- **Updated:** 7 Jan 2025
- **Also known as:** GHSA-r5vf-wf4h-82gg, RUSTSEC-2024-0434, openSUSE-SU-2025:14726-1

## What is CVE-2024-52813?

CVE-2024-52813 is a medium-severity vulnerability in matrix-org matrix-rust-sdk, published on 7 Jan 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

matrix-rust-sdk is an implementation of a Matrix client-server library in Rust. Versions of the matrix-sdk-crypto Rust crate before 0.8.0 lack a dedicated mechanism to notify that a user's cryptographic identity has changed from a verified to an unverified one, which could cause client applications relying on the SDK to overlook such changes. matrix-sdk-crypto 0.8.0 adds a new VerificationLevel::VerificationViolation enum variant which indicates that a previously verified identity has been changed.

Weakness: CWE-223 (Omission of Security-relevant Information)

## Which versions are affected by CVE-2024-52813?

3 open source packages ship an affected version, including matrix-sdk-crypto.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `matrix-sdk-crypto` | crates.io | All versions | 0.8.0 |
| `matrix-sdk-crypto` | crates.io | All versions | 0.8.0 |
| `matrix-sdk-crypto` | crates.io | From 0.0.0-0 | 0.8.0 |
| `cargo-audit-advisory-db` | openSUSE:Tumbleweed | All versions | 20250204-1.1 |

## How do I fix CVE-2024-52813?

Upgrade matrix-sdk-crypto to 0.8.0 or later.

## Is CVE-2024-52813 being exploited?

There is no known exploitation of CVE-2024-52813 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-52813 and fix it if it is affected.

What it is: CVE-2024-52813 is a medium-severity vulnerability in matrix-org matrix-rust-sdk, published on 7 Jan 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-52813 in the wild and no public exploit code.

Affected packages and fixed versions:
- matrix-sdk-crypto (crates.io): affected all versions; fixed in 0.8.0
- matrix-sdk-crypto (crates.io): affected all versions; fixed in 0.8.0
- matrix-sdk-crypto (crates.io): affected from 0.0.0-0; fixed in 0.8.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-52813/ (Markdown: https://insights.sbomify.com/CVE-2024-52813/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-52813
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-52813
- OSV: https://osv.dev/vulnerability/CVE-2024-52813

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-52813/
Summaries are generated and may contain mistakes; the official description above is the record.
