# CVE-2024-52980: Elasticsearch Uncontrolled Resource Consumption vulnerability

> A malicious user with read_pipeline privileges can crash Elasticsearch nodes via uncontrolled recursion in the PatternBank class.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Apr 2025
- **Updated:** 8 Apr 2025
- **Also known as:** BIT-elasticsearch-2024-52980, ECHO-912e-995e-04ac, GHSA-ghfh-p92w-j4mg, MINI-5xwf-8j95-q6gc, MINI-m7w8-vxp2-5qmw, UBUNTU-CVE-2024-52980

## What is CVE-2024-52980?

CVE-2024-52980 is a medium-severity denial of service vulnerability in Elastic Elasticsearch, published on 8 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A flaw was discovered in Elasticsearch, where a large recursion using the innerForbidCircularReferences function of the PatternBank class could cause the Elasticsearch node to crash.

A successful attack requires a malicious user to have read_pipeline Elasticsearch cluster privilege assigned to them.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2024-52980?

3 open source packages ship an affected version, including org.elasticsearch:elasticsearch-grok and elasticsearch. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.elasticsearch:elasticsearch-grok` | Maven | From 7.17.0 | 8.15.1 |
| `org.elasticsearch:elasticsearch-grok` | Maven | From 7.17.0 | 8.15.1 |
| `elasticsearch` | Bitnami | From 7.17.0 | 8.15.1 |

Products: Elastic Elasticsearch.

## How do I fix CVE-2024-52980?

Upgrade org.elasticsearch:elasticsearch-grok to 8.15.1 or later.

## Is CVE-2024-52980 being exploited?

There is no known exploitation of CVE-2024-52980 in the wild and no public exploit code.

## Other vulnerabilities in Elastic Elasticsearch

- [CVE-2015-1427](https://insights.sbomify.com/CVE-2015-1427/): Elasticsearch Groovy Scripting Engine Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2014-3120](https://insights.sbomify.com/CVE-2014-3120/): Elasticsearch Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2015-5377](https://insights.sbomify.com/CVE-2015-5377/): Code injection in n/a (critical 9.8)
- [CVE-2026-72649](https://insights.sbomify.com/CVE-2026-72649/): Deserialization of Untrusted Data in Elasticsearch Leading to Remote Code Execution (high 8.8)
- [CVE-2026-72642](https://insights.sbomify.com/CVE-2026-72642/): Use of Out-of-range Pointer Offset in the Elasticsearch Machine Learning Native Inference Process (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-52980 and fix it if it is affected.

What it is: CVE-2024-52980 is a medium-severity denial of service vulnerability in Elastic Elasticsearch, published on 8 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-52980 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.elasticsearch:elasticsearch-grok (Maven): affected from 7.17.0; fixed in 8.15.1
- org.elasticsearch:elasticsearch-grok (Maven): affected from 7.17.0; fixed in 8.15.1
- elasticsearch (Bitnami): affected from 7.17.0; fixed in 8.15.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-52980/ (Markdown: https://insights.sbomify.com/CVE-2024-52980/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-52980
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-52980
- OSV: https://osv.dev/vulnerability/CVE-2024-52980

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-52980/
Summaries are generated and may contain mistakes; the official description above is the record.
