# CVE-2024-5312: Cross-Site Scripting vulnerability in PHP Server Monitor

> An attacker can execute arbitrary scripts in a victim's browser via a crafted URL, potentially stealing session details in PHP Server Monitor.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 May 2024
- **Updated:** 1 Aug 2024
- **Also known as:** GHSA-rq7f-j68f-mqh3

## What is CVE-2024-5312?

CVE-2024-5312 is a medium-severity cross-site scripting vulnerability in PHP Server Monitor, published on 24 May 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

PHP Server Monitor, version 3.2.0, is vulnerable to an XSS via the /phpservermon-3.2.0/vendor/phpmailer/phpmailer/test_script/index.php page in all visible parameters. An attacker could create a specially crafted URL, send it to a victim and retrieve their session details.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-5312?

2 open source packages ship an affected version, including phpservermon/phpservermon.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phpservermon/phpservermon` | Packagist | All versions | 3.3.0 |
| `phpservermon/phpservermon` | Packagist | All versions | 3.3.0 |

## How do I fix CVE-2024-5312?

Upgrade phpservermon/phpservermon to 3.3.0 or later.

## Is CVE-2024-5312 being exploited?

There is no known exploitation of CVE-2024-5312 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-5312 and fix it if it is affected.

What it is: CVE-2024-5312 is a medium-severity cross-site scripting vulnerability in PHP Server Monitor, published on 24 May 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-5312 in the wild and no public exploit code.

Affected packages and fixed versions:
- phpservermon/phpservermon (Packagist): affected all versions; fixed in 3.3.0
- phpservermon/phpservermon (Packagist): affected all versions; fixed in 3.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-5312/ (Markdown: https://insights.sbomify.com/CVE-2024-5312/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-5312
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-5312
- OSV: https://osv.dev/vulnerability/CVE-2024-5312

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-5312/
Summaries are generated and may contain mistakes; the official description above is the record.
