# CVE-2024-5314: Multiple vulnerabilities in DOLIBARR's ERP CMS

> Remote attackers can exploit SQL injection in Dolibarr ERP to retrieve all database information via crafted queries in the admin dictionary module.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 May 2024
- **Updated:** 1 Aug 2024
- **Also known as:** BIT-dolibarr-2024-5314, GHSA-c3h9-q3jx-w7fc, UBUNTU-CVE-2024-5314

## What is CVE-2024-5314?

CVE-2024-5314 is a critical SQL injection vulnerability in Dolibarr Dolibarr Erp\/Crm, published on 24 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Vulnerabilities in Dolibarr ERP - CRM that affect version 9.0.1 and allow SQL injection. These vulnerabilities could allow a remote attacker to send a specially crafted SQL query to the system and retrieve all the information stored in the database through the parameters sortorder y sortfield in /dolibarr/admin/dict.php.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2024-5314?

3 open source packages ship an affected version, including dolibarr/dolibarr and dolibarr. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dolibarr/dolibarr` | Packagist | All versions to 9.0.1 | None |
| `dolibarr/dolibarr` | Packagist | All versions to 9.0.1 | None |
| `dolibarr` | Bitnami | From 9.0.1 | 18.0.5 |

Products: Dolibarr Dolibarr Erp\/Crm.

## How do I fix CVE-2024-5314?

Upgrade to a fixed version.

## Is CVE-2024-5314 being exploited?

There is no known exploitation of CVE-2024-5314 in the wild and no public exploit code.

## Other vulnerabilities in Dolibarr Dolibarr Erp\/Crm

- [CVE-2022-43138](https://insights.sbomify.com/CVE-2022-43138/): Dolibarr vulnerable to privilege escalation (critical 9.8)
- [CVE-2022-40871](https://insights.sbomify.com/CVE-2022-40871/): Dolibarr vulnerable to Eval Injection (critical 9.8)
- [CVE-2021-33816](https://insights.sbomify.com/CVE-2021-33816/): Dolibarr remote PHP code execution (critical 9.8)
- [CVE-2020-7995](https://insights.sbomify.com/CVE-2020-7995/): Dolibarr Improper Restriction of Excessive Authentication Attempts (critical 9.8)
- [CVE-2013-2091](https://insights.sbomify.com/CVE-2013-2091/): SQL injection in dolibarr (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-5314 and fix it if it is affected.

What it is: CVE-2024-5314 is a critical SQL injection vulnerability in Dolibarr Dolibarr Erp\/Crm, published on 24 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-5314 in the wild and no public exploit code.

Affected packages and fixed versions:
- dolibarr/dolibarr (Packagist): affected all versions up to 9.0.1; no fix listed
- dolibarr/dolibarr (Packagist): affected all versions up to 9.0.1; no fix listed
- dolibarr (Bitnami): affected from 9.0.1; fixed in 18.0.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-5314/ (Markdown: https://insights.sbomify.com/CVE-2024-5314/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-5314
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-5314
- OSV: https://osv.dev/vulnerability/CVE-2024-5314

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-5314/
Summaries are generated and may contain mistakes; the official description above is the record.
