CVE-2024-53259 quic-go affected by an ICMP Packet Too Large Injection Attack on Linux
An off-path attacker can disrupt QUIC connections by injecting ICMP Packet Too Large messages, causing denial of service in applications using the quic-go library.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-53259?
CVE-2024-53259 is a medium-severity denial of service vulnerability in quic-go, published on 2 Dec 2024. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
quic-go is an implementation of the QUIC protocol in Go. An off-path attacker can inject an ICMP Packet Too Large packet. Since affected quic-go versions used IP_PMTUDISC_DO, the kernel would then return a "message too large" error on sendmsg, i.e. when quic-go attempts to send a packet that exceeds the MTU claimed in that ICMP packet. By setting this value to smaller than 1200 bytes (the minimum MTU for QUIC), the attacker can disrupt a QUIC connection. Crucially, this can be done after completion of the handshake, thereby circumventing any TCP fallback that might be implemented on the application layer (for example, many browsers fall back to HTTP over TCP if they're unable to establish a QUIC connection). The attacker needs to at least know the client's IP and port tuple to mount an attack. This vulnerability is fixed in 0.48.2.
Weakness: CWE-345
Which versions are affected by CVE-2024-53259?
3 open source packages ship an affected version, including github.com/quic-go/quic-go.
| Package | Affected | Fixed in |
|---|---|---|
github.com/quic-go/quic-go Go | All versions | 0.48.2 |
github.com/quic-go/quic-go Go | All versions | 0.48.2 |
github.com/quic-go/quic-go Go | All versions | 0.48.2 |
Linux distribution packages (1)
teleport openSUSE:Tumbleweed | All versions | 17.0.3-1.1 |
How do I fix CVE-2024-53259?
Upgrade github.com/quic-go/quic-go to 0.48.2 or later.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2024-53259 being exploited?
There is no known exploitation of CVE-2024-53259 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Sources
Also known as AZL-53807, AZL-53818, CLEANSTART-2026-BB24925, DEBIAN-CVE-2024-53259, GHSA-px8v-pp82-rcvr, GO-2024-3302 and 11 more.