# CVE-2024-53259: quic-go affected by an ICMP Packet Too Large Injection Attack on Linux

> An off-path attacker can disrupt QUIC connections by injecting ICMP Packet Too Large messages, causing denial of service in applications using the quic-go library.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Dec 2024
- **Updated:** 2 Dec 2024
- **Also known as:** AZL-53807, AZL-53818, CLEANSTART-2026-BB24925, DEBIAN-CVE-2024-53259, GHSA-px8v-pp82-rcvr, GO-2024-3302, MINI-2hj8-5vx9-w6gq, MINI-65c2-6prp-p67w, MINI-6q7f-mw3p-p4r3, MINI-cf6v-2mv9-656g, MINI-ghp8-2v87-5pwh, MINI-gwx7-r66j-57f2, MINI-qhjg-p49f-57g8, MINI-v3fm-gj86-72jw, MINI-whrp-g37h-7mcf, UBUNTU-CVE-2024-53259, openSUSE-SU-2024:14544-1

## What is CVE-2024-53259?

CVE-2024-53259 is a medium-severity denial of service vulnerability in quic-go, published on 2 Dec 2024. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

quic-go is an implementation of the QUIC protocol in Go. An off-path attacker can inject an ICMP Packet Too Large packet. Since affected quic-go versions used IP_PMTUDISC_DO, the kernel would then return a "message too large" error on sendmsg, i.e. when quic-go attempts to send a packet that exceeds the MTU claimed in that ICMP packet. By setting this value to smaller than 1200 bytes (the minimum MTU for QUIC), the attacker can disrupt a QUIC connection. Crucially, this can be done after completion of the handshake, thereby circumventing any TCP fallback that might be implemented on the application layer (for example, many browsers fall back to HTTP over TCP if they're unable to establish a QUIC connection). The attacker needs to at least know the client's IP and port tuple to mount an attack. This vulnerability is fixed in 0.48.2.

Weakness: CWE-345 (Insufficient Verification of Data Authenticity)

## Which versions are affected by CVE-2024-53259?

3 open source packages ship an affected version, including github.com/quic-go/quic-go.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/quic-go/quic-go` | Go | All versions | 0.48.2 |
| `github.com/quic-go/quic-go` | Go | All versions | 0.48.2 |
| `github.com/quic-go/quic-go` | Go | All versions | 0.48.2 |
| `teleport` | openSUSE:Tumbleweed | All versions | 17.0.3-1.1 |

## How do I fix CVE-2024-53259?

Upgrade github.com/quic-go/quic-go to 0.48.2 or later.

## Is CVE-2024-53259 being exploited?

There is no known exploitation of CVE-2024-53259 in the wild and no public exploit code.

Public exploit code:

- https://github.com/kota-yata/cve-2024-53259 (github_poc): https://github.com/kota-yata/cve-2024-53259

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-53259 and fix it if it is affected.

What it is: CVE-2024-53259 is a medium-severity denial of service vulnerability in quic-go, published on 2 Dec 2024. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-53259 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/quic-go/quic-go (Go): affected all versions; fixed in 0.48.2
- github.com/quic-go/quic-go (Go): affected all versions; fixed in 0.48.2
- github.com/quic-go/quic-go (Go): affected all versions; fixed in 0.48.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-53259/ (Markdown: https://insights.sbomify.com/CVE-2024-53259/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-53259
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-53259
- OSV: https://osv.dev/vulnerability/CVE-2024-53259

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-53259/
Summaries are generated and may contain mistakes; the official description above is the record.
