{"answers":{"affected":"2 open source packages ship an affected version, including @sveltejs/kit. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-53262 in the wild and no public exploit code.","fix":"Upgrade @sveltejs/kit to 2.8.3 or later.","what":"CVE-2024-53262 is a low-severity cross-site scripting vulnerability in sveltejs kit, published on 25 Nov 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-53262 and fix it if it is affected.\n\nWhat it is: CVE-2024-53262 is a low-severity cross-site scripting vulnerability in sveltejs kit, published on 25 Nov 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-53262 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @sveltejs/kit (npm): affected all versions; fixed in 2.8.3\n- @sveltejs/kit (npm): affected all versions; fixed in 2.8.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-53262/ (Markdown: https://insights.sbomify.com/CVE-2024-53262/index.md)","id":"CVE-2024-53262","markdown":"https://insights.sbomify.com/CVE-2024-53262/index.md","name":"CVE-2024-53262","record":{"aliases":["GHSA-mh2x-fcqh-fmqv"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"SvelteKit web framework","requires_auth":"low_privilege","summary":"Attackers can inject scripts via unescaped error messages in SvelteKit applications that explicitly use user input in error objects.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"sveltekit","vendor":"svelte"}],"cvss":{"score":2,"severity":"low","source":"cna","vector":"CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:A/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"SvelteKit is a framework for rapidly developing robust, performant web applications using Svelte. The static error.html template for errors contains placeholders that are replaced without escaping the content first. error.html is the page that is rendered when everything else fails. It can contain the following placeholders: %sveltekit.status% — the HTTP status, and %sveltekit.error.message% — the error message.  This leads to possible injection if an app explicitly creates an error with a message that contains user controlled content. Only applications where user provided input is used in the `Error` message will be vulnerable, so the vast majority of applications will not be vulnerable This issue has been addressed in version 2.8.3 and all users are advised to upgrade. There are no known workarounds for this vulnerability.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Unescaped error message included on error page in SvelteKit","id":"CVE-2024-53262","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2024"},"n_packages":2,"n_references":3,"next":{"headline":"Git LFS permits exfiltration of credentials via crafted HTTP URLs","id":"CVE-2024-53263"},"packages":[{"ecosystem":"npm","fixed":["2.8.3"],"introduced":["0"],"last_affected":[],"package":"@sveltejs/kit","purl":null,"source":"GHSA-mh2x-fcqh-fmqv"},{"ecosystem":"npm","fixed":["2.8.3"],"introduced":["0"],"last_affected":[],"package":"@sveltejs/kit","purl":"pkg:npm/%40sveltejs/kit","source":"GHSA-mh2x-fcqh-fmqv"}],"prev":{"headline":"Cross-Site Scripting attack (XSS) on dev mode 404 page in SvelteKit","id":"CVE-2024-53261"},"products":["kit"],"published":"2024-11-25","related":[{"cvss_score":8.8,"headline":"SvelteKit framework has Insufficient CSRF protection for CORS requests","id":"CVE-2023-29008","kev_date_added":null,"published":"2023-04-06"},{"cvss_score":8.8,"headline":"SvelteKit has Insufficient Cross-Site Request Forgery Protection","id":"CVE-2023-29003","kev_date_added":null,"published":"2023-04-04"},{"cvss_score":8.7,"headline":"SvelteKit 2.49.0 before 2.53.3 Denial of Service via form","id":"CVE-2026-82259","kev_date_added":null,"published":"2026-08-28"},{"cvss_score":8.7,"headline":"SvelteKit before 2.52.2 Memory Exhaustion via Remote Form Deserialization","id":"CVE-2026-82260","kev_date_added":null,"published":"2026-08-28"},{"cvss_score":8.7,"headline":"SvelteKit before 2.52.2 CPU Exhaustion via Remote Form Deserialization","id":"CVE-2026-82261","kev_date_added":null,"published":"2026-08-28"},{"cvss_score":6.9,"headline":"SvelteKit before 2.69.1 Denial of Service via Remote Form","id":"CVE-2026-82256","kev_date_added":null,"published":"2026-08-28"},{"cvss_score":5.9,"headline":"SvelteKit 2.38.0 before 2.60.1 Cross-User Data Disclosure via query.batch","id":"CVE-2026-82258","kev_date_added":null,"published":"2026-08-28"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-11-25","vendors":["sveltejs"]},"summary":"Attackers can inject scripts via unescaped error messages in SvelteKit applications that explicitly use user input in error objects.","url":"https://insights.sbomify.com/CVE-2024-53262/"}