{"answers":{"affected":"3 open source packages ship an affected version, including github.com/bunkerity/bunkerweb.","exploited":"There is no known exploitation of CVE-2024-53264 in the wild and no public exploit code.","fix":"Upgrade github.com/bunkerity/bunkerweb to 1.5.11 or later.","what":"CVE-2024-53264 is a medium-severity vulnerability in bunkerity bunkerweb, published on 27 Nov 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-53264 and fix it if it is affected.\n\nWhat it is: CVE-2024-53264 is a medium-severity vulnerability in bunkerity bunkerweb, published on 27 Nov 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-53264 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/bunkerity/bunkerweb (Go): affected all versions; fixed in 1.5.11\n- github.com/bunkerity/bunkerweb (Go): affected all versions; fixed in 1.5.11\n- github.com/bunkerity/bunkerweb (Go): affected all versions; fixed in 1.5.11\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-53264/ (Markdown: https://insights.sbomify.com/CVE-2024-53264/index.md)","id":"CVE-2024-53264","markdown":"https://insights.sbomify.com/CVE-2024-53264/index.md","name":"CVE-2024-53264","record":{"aliases":["GHSA-q9rr-h3hx-m87g","GO-2024-3294"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Web Application Firewall","requires_auth":"none","summary":"Attackers can redirect authenticated users to malicious sites via an unvalidated parameter in the loading endpoint, facilitating phishing attacks.","user_interaction":"required","vuln_class":"open_redirect"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":5.1,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-601","name":"URL Redirection to Untrusted Site"}],"description":"bunkerweb is an Open-source and next-generation Web Application Firewall (WAF). A open redirect vulnerability exists in the loading endpoint, allowing attackers to redirect authenticated users to arbitrary external URLs via the \"next\" parameter. The loading endpoint accepts and uses an unvalidated \"next\" parameter for redirects. Ex. visiting: `/loading?next=https://google.com` while authenticated will cause the page will redirect to google.com. This vulnerability could be used in phishing attacks by redirecting users from a legitimate application URL to malicious sites. This issue has been addressed in version 1.5.11. Users are advised to upgrade. There are no known workarounds for this vulnerability.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Open Redirect Vulnerability in Loading Page in bunkerweb","id":"CVE-2024-53264","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"open_redirect","year":"2024"},"n_packages":3,"n_references":1,"next":{"headline":"Cross-site Scripting (XSS) via topic titles when CSP disabled in Discourse","id":"CVE-2024-53266"},"packages":[{"ecosystem":"Go","fixed":["1.5.11"],"introduced":["0"],"last_affected":[],"package":"github.com/bunkerity/bunkerweb","purl":null,"source":"GHSA-q9rr-h3hx-m87g"},{"ecosystem":"Go","fixed":["1.5.11"],"introduced":["0"],"last_affected":[],"package":"github.com/bunkerity/bunkerweb","purl":"pkg:golang/github.com/bunkerity/bunkerweb","source":"GHSA-q9rr-h3hx-m87g"},{"ecosystem":"Go","fixed":["1.5.11"],"introduced":["0"],"last_affected":[],"package":"github.com/bunkerity/bunkerweb","purl":"pkg:golang/github.com/bunkerity/bunkerweb","source":"GO-2024-3294"}],"prev":{"headline":"Git LFS permits exfiltration of credentials via crafted HTTP URLs","id":"CVE-2024-53263"},"products":["bunkerweb"],"published":"2024-11-27","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-11-27","vendors":["bunkerity"]},"summary":"Attackers can redirect authenticated users to malicious sites via an unvalidated parameter in the loading endpoint, facilitating phishing attacks.","url":"https://insights.sbomify.com/CVE-2024-53264/"}