CVE-2024-53267 Vulnerability with bundle verification in sigstore-java

Medium 5.5 Published Updated

Attackers can bypass transparency log verification in sigstore-java, allowing malicious artifacts to appear legitimately signed without proper logging proof.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2024-53267?

CVE-2024-53267 is a medium-severity vulnerability in sigstore-java, published on 26 Nov 2024. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

sigstore-java is a sigstore java client for interacting with sigstore infrastructure. sigstore-java has insufficient verification for a situation where a validly-signed but "mismatched" bundle is presented as proof of inclusion into a transparency log. This bug impacts clients using any variation of KeylessVerifier.verify(). The verifier may accept a bundle with an unrelated log entry, cryptographically verifying everything but fails to ensure the log entry applies to the artifact in question, thereby "verifying" a bundle without any proof the signing event was logged. This allows the creation of a bundle without fulcio certificate and private key combined with an unrelated but time-correct log entry to fake logging of a signing event. A malicious actor using a compromised identity may want to do this to prevent discovery via rekor's log monitors. The signer's identity will still be available to the verifier. The signature on the bundle must still be on the correct artifact for the verifier to pass. sigstore-gradle-plugin and sigstore-maven-plugin are not affected by this as they only provide signing functionality. This issue has been patched in v1.1.0 release with PR #856. All users are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-347

Which versions are affected by CVE-2024-53267?

2 open source packages ship an affected version, including dev.sigstore:sigstore-java.

PackageAffectedFixed in
dev.sigstore:sigstore-java MavenFrom 1.0.01.1.0
dev.sigstore:sigstore-java MavenFrom 1.0.01.1.0

How do I fix CVE-2024-53267?

Upgrade dev.sigstore:sigstore-java to 1.1.0 or later.

Is CVE-2024-53267 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-53267 exists.

Sources

Also known as GHSA-q4xm-6fjc-5f6w.

Is CVE-2024-53267 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free