{"answers":{"affected":"3 open source packages ship an affected version, including whoogle-search. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-53305 in the wild and no public exploit code.","fix":"Upgrade whoogle-search to 0.9.1 or later.","what":"CVE-2024-53305 is a high-severity command injection vulnerability in n/a, published on 16 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-53305 and fix it if it is affected.\n\nWhat it is: CVE-2024-53305 is a high-severity command injection vulnerability in n/a, published on 16 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-53305 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- whoogle-search (PyPI): affected all versions; fixed in 0.9.1\n- whoogle-search (PyPI): affected all versions; fixed in 0.9.1\n- whoogle-search (PyPI): affected all versions; fixed in 0.9.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-53305/ (Markdown: https://insights.sbomify.com/CVE-2024-53305/index.md)","id":"CVE-2024-53305","markdown":"https://insights.sbomify.com/CVE-2024-53305/index.md","name":"CVE-2024-53305","record":{"aliases":["GHSA-2689-cw26-6cpj","PYSEC-2026-2048"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Whoogle search","requires_auth":"none","summary":"Attackers can execute arbitrary code in Whoogle search by supplying a crafted search query, requiring immediate upgrade.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"whoogle_search","vendor":"benbusby"}],"cvss":{"score":7.3,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-77","name":"Improper Neutralization of Special Elements used in a Command"}],"description":"An issue in the component /models/config.py of Whoogle search v0.9.0 allows attackers to execute arbitrary code via supplying a crafted search query.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Whoogle allows attackers to execute arbitrary code via supplying a crafted search query","id":"CVE-2024-53305","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"command_injection","year":"2024"},"n_packages":3,"n_references":2,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2024-53307"},"packages":[{"ecosystem":"PyPI","fixed":["0.9.1"],"introduced":["0"],"last_affected":[],"package":"whoogle-search","purl":null,"source":"GHSA-2689-cw26-6cpj"},{"ecosystem":"PyPI","fixed":["0.9.1"],"introduced":["0"],"last_affected":[],"package":"whoogle-search","purl":"pkg:pypi/whoogle-search","source":"GHSA-2689-cw26-6cpj"},{"ecosystem":"PyPI","fixed":["0.9.1"],"introduced":["0"],"last_affected":[],"package":"whoogle-search","purl":"pkg:pypi/whoogle-search","source":"PYSEC-2026-2048"}],"prev":{"headline":"Auth bypass in n/a","id":"CVE-2024-53304"},"products":["n/a"],"published":"2025-04-16","related":[{"cvss_score":9.1,"headline":"Whoogle Search Server Side Request Forgery vulnerability","id":"CVE-2024-22203","kev_date_added":null,"published":"2024-01-23"},{"cvss_score":9.1,"headline":"Whoogle Search Server Side Request Forgery vulnerability","id":"CVE-2024-22205","kev_date_added":null,"published":"2024-01-23"},{"cvss_score":6.1,"headline":"Whoogle Search Cross-site Scripting vulnerability","id":"CVE-2024-22417","kev_date_added":null,"published":"2024-01-23"},{"cvss_score":5.3,"headline":"Whoogle Search Limited File Write vulnerability","id":"CVE-2024-22204","kev_date_added":null,"published":"2024-01-23"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-04-16","vendors":["n/a"]},"summary":"Attackers can execute arbitrary code in Whoogle search by supplying a crafted search query, requiring immediate upgrade.","url":"https://insights.sbomify.com/CVE-2024-53305/"}