{"answers":{"affected":"2 open source packages ship an affected version, including prismjs. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-53382 exists.","fix":"Upgrade prismjs to 1.30.0 or later.","what":"CVE-2024-53382 is a medium-severity cross-site scripting vulnerability in PrismJS Prism, published on 3 Mar 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-53382 and fix it if it is affected.\n\nWhat it is: CVE-2024-53382 is a medium-severity cross-site scripting vulnerability in PrismJS Prism, published on 3 Mar 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-53382 exists.\n\nAffected packages and fixed versions:\n- prismjs (npm): affected all versions; fixed in 1.30.0\n- prismjs (npm): affected all versions; fixed in 1.30.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-53382/ (Markdown: https://insights.sbomify.com/CVE-2024-53382/index.md)","id":"CVE-2024-53382","markdown":"https://insights.sbomify.com/CVE-2024-53382/index.md","name":"CVE-2024-53382","record":{"aliases":["CLEANSTART-2026-CB71231","CLEANSTART-2026-VC34958","CLSA-2026-1778719550","CLSA-2026-1778719553","DEBIAN-CVE-2024-53382","ECHO-974c-0e23-847e","GHSA-x7hr-w5r2-h6wg","MINI-746r-fq7h-8ccg","MINI-8c8g-9ppv-c4pj","MINI-92mm-8fmg-44cr","MINI-9j5x-5xvf-7w39","MINI-9vmv-qmc9-j48r","MINI-c95c-h2m5-vxc3","MINI-h6hw-mrmg-gm3m","MINI-mxj8-pxrw-hf57","MINI-rp39-2q76-54qm","MINI-vr67-3j32-wwqr","MINI-w592-2wfj-ppcq","ROOT-APP-NPM-CVE-2024-53382","UBUNTU-CVE-2024-53382"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript syntax highlighting library","requires_auth":"low_privilege","summary":"Attacker can execute arbitrary JavaScript via DOM Clobbering in PrismJS when processing untrusted HTML input.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"prism","vendor":"prismjs"}],"cvss":{"score":4.9,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"},{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"Prism (aka PrismJS) through 1.29.0 allows DOM Clobbering (with resultant XSS for untrusted input that contains HTML but does not directly contain JavaScript), because document.currentScript lookup can be shadowed by attacker-injected HTML elements.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"PrismJS DOM Clobbering vulnerability","id":"CVE-2024-53382","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2024"},"n_packages":2,"n_references":2,"next":{"headline":"tsup DOM Clobbering vulnerability","id":"CVE-2024-53384"},"packages":[{"ecosystem":"npm","fixed":["1.30.0"],"introduced":["0"],"last_affected":[],"package":"prismjs","purl":null,"source":"GHSA-x7hr-w5r2-h6wg"},{"ecosystem":"npm","fixed":["1.30.0"],"introduced":["0"],"last_affected":[],"package":"prismjs","purl":"pkg:npm/prismjs","source":"GHSA-x7hr-w5r2-h6wg"}],"prev":{"headline":"Memory corruption in n/a","id":"CVE-2024-53379"},"products":["Prism"],"published":"2025-03-03","related":[{"cvss_score":7.5,"headline":"Cross-site Scripting in Prism","id":"CVE-2022-23647","kev_date_added":null,"published":"2022-02-18"},{"cvss_score":7.5,"headline":"Inefficient Regular Expression Complexity in prismjs/prism","id":"CVE-2021-3801","kev_date_added":null,"published":"2021-09-15"},{"cvss_score":7.5,"headline":"Regular Expression Denial of Service (ReDoS)","id":"CVE-2021-23341","kev_date_added":null,"published":"2021-02-18"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-03-03","vendors":["PrismJS"]},"summary":"Attacker can execute arbitrary JavaScript via DOM Clobbering in PrismJS when processing untrusted HTML input.","url":"https://insights.sbomify.com/CVE-2024-53382/"}