# CVE-2024-53382: PrismJS DOM Clobbering vulnerability

> Attacker can execute arbitrary JavaScript via DOM Clobbering in PrismJS when processing untrusted HTML input.

- **Severity:** Medium 4.9 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Mar 2025
- **Updated:** 3 Mar 2025
- **Also known as:** CLEANSTART-2026-CB71231, CLEANSTART-2026-VC34958, CLSA-2026-1778719550, CLSA-2026-1778719553, DEBIAN-CVE-2024-53382, ECHO-974c-0e23-847e, GHSA-x7hr-w5r2-h6wg, MINI-746r-fq7h-8ccg, MINI-8c8g-9ppv-c4pj, MINI-92mm-8fmg-44cr, MINI-9j5x-5xvf-7w39, MINI-9vmv-qmc9-j48r, MINI-c95c-h2m5-vxc3, MINI-h6hw-mrmg-gm3m, MINI-mxj8-pxrw-hf57, MINI-rp39-2q76-54qm, MINI-vr67-3j32-wwqr, MINI-w592-2wfj-ppcq, ROOT-APP-NPM-CVE-2024-53382, UBUNTU-CVE-2024-53382

## What is CVE-2024-53382?

CVE-2024-53382 is a medium-severity cross-site scripting vulnerability in PrismJS Prism, published on 3 Mar 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Prism (aka PrismJS) through 1.29.0 allows DOM Clobbering (with resultant XSS for untrusted input that contains HTML but does not directly contain JavaScript), because document.currentScript lookup can be shadowed by attacker-injected HTML elements.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2024-53382?

2 open source packages ship an affected version, including prismjs. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `prismjs` | npm | All versions | 1.30.0 |
| `prismjs` | npm | All versions | 1.30.0 |

Products: Prismjs Prism.

## How do I fix CVE-2024-53382?

Upgrade prismjs to 1.30.0 or later.

## Is CVE-2024-53382 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-53382 exists.

## Other vulnerabilities in PrismJS Prism

- [CVE-2022-23647](https://insights.sbomify.com/CVE-2022-23647/): Cross-site Scripting in Prism (high 7.5)
- [CVE-2021-3801](https://insights.sbomify.com/CVE-2021-3801/): Inefficient Regular Expression Complexity in prismjs/prism (high 7.5)
- [CVE-2021-23341](https://insights.sbomify.com/CVE-2021-23341/): Regular Expression Denial of Service (ReDoS) (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-53382 and fix it if it is affected.

What it is: CVE-2024-53382 is a medium-severity cross-site scripting vulnerability in PrismJS Prism, published on 3 Mar 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-53382 exists.

Affected packages and fixed versions:
- prismjs (npm): affected all versions; fixed in 1.30.0
- prismjs (npm): affected all versions; fixed in 1.30.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-53382/ (Markdown: https://insights.sbomify.com/CVE-2024-53382/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-53382
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-53382
- OSV: https://osv.dev/vulnerability/CVE-2024-53382

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-53382/
Summaries are generated and may contain mistakes; the official description above is the record.
