# CVE-2024-53526: Composio Command Execution vulnerability

> Attackers can execute arbitrary commands via the handle_tool_calls function in the composio library, requiring an upgrade to mitigate.

- **Severity:** Medium 6.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Jan 2025
- **Updated:** 31 Jan 2025
- **Also known as:** GHSA-8h93-28hg-fj84, PYSEC-2026-1268, PYSEC-2026-2428, PYSEC-2026-2429

## What is CVE-2024-53526?

CVE-2024-53526 is a medium-severity command injection vulnerability in n/a, published on 8 Jan 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

composio >=0.5.40 is vulnerable to Command Execution in composio_openai, composio_claude, and composio_julep via the handle_tool_calls function.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2024-53526?

9 open source packages ship an affected version, including composio-claude, composio-julep and composio-openai. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `composio-claude` | PyPI | From 0.5.40 | 0.6.9 |
| `composio-claude` | PyPI | From 0.5.40 | 0.6.9 |
| `composio-claude` | PyPI | From 0.5.40 | 0.6.9 |
| `composio-julep` | PyPI | From 0.5.40 | 0.6.9 |
| `composio-julep` | PyPI | From 0.5.40 | 0.6.9 |
| `composio-julep` | PyPI | From 0.5.40 | 0.6.9 |
| `composio-openai` | PyPI | From 0.5.40 | 0.6.9 |
| `composio-openai` | PyPI | From 0.5.40 | 0.6.9 |
| `composio-openai` | PyPI | From 0.5.40 | 0.6.9 |

Products: Composio Composio.

## How do I fix CVE-2024-53526?

Upgrade composio-claude to 0.6.9 or later.

## Is CVE-2024-53526 being exploited?

There is no known exploitation of CVE-2024-53526 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2024-8954](https://insights.sbomify.com/CVE-2024-8954/): Authentication Bypass in composiohq/composio (critical 9.8)
- [CVE-2025-56427](https://insights.sbomify.com/CVE-2025-56427/): ComposioHQ has a directory traversal vulnerability (high 7.5)
- [CVE-2024-8953](https://insights.sbomify.com/CVE-2024-8953/): Unsafe eval usage in composiohq/composio (high 7.2)
- [CVE-2024-8958](https://insights.sbomify.com/CVE-2024-8958/): Unrestricted File Write and Read in composiohq/composio (high 7.2)
- [CVE-2024-8952](https://insights.sbomify.com/CVE-2024-8952/): SSRF in composiohq/composio (medium 6.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-53526 and fix it if it is affected.

What it is: CVE-2024-53526 is a medium-severity command injection vulnerability in n/a, published on 8 Jan 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-53526 in the wild and no public exploit code.

Affected packages and fixed versions:
- composio-claude (PyPI): affected from 0.5.40; fixed in 0.6.9
- composio-claude (PyPI): affected from 0.5.40; fixed in 0.6.9
- composio-claude (PyPI): affected from 0.5.40; fixed in 0.6.9
- composio-julep (PyPI): affected from 0.5.40; fixed in 0.6.9
- composio-julep (PyPI): affected from 0.5.40; fixed in 0.6.9
- composio-julep (PyPI): affected from 0.5.40; fixed in 0.6.9
- composio-openai (PyPI): affected from 0.5.40; fixed in 0.6.9
- composio-openai (PyPI): affected from 0.5.40; fixed in 0.6.9
- composio-openai (PyPI): affected from 0.5.40; fixed in 0.6.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-53526/ (Markdown: https://insights.sbomify.com/CVE-2024-53526/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-53526
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-53526
- OSV: https://osv.dev/vulnerability/CVE-2024-53526

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-53526/
Summaries are generated and may contain mistakes; the official description above is the record.
