# CVE-2024-53677: Apache Struts: Mixing setters for uploaded files and normal fields can allow bypass file upload checks

> Attackers can bypass file upload checks to upload malicious files and execute remote code in applications using legacy Struts file upload logic.

- **Severity:** Critical 9.5 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H/S:N/AU:Y/R:A/V:C/RE:L/U:Red`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Dec 2024
- **Updated:** 3 Jan 2025
- **Also known as:** CLSA-2025-1754006617, GHSA-43mq-6xmg-29vm

## What is CVE-2024-53677?

CVE-2024-53677 is a critical vulnerability in Apache Struts, published on 11 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

File upload logic in Apache Struts is flawed. An attacker can manipulate file upload params to enable paths traversal and under some circumstances this can lead to uploading a malicious file which can be used to perform Remote Code Execution.

This issue affects Apache Struts: from 2.0.0 before 6.4.0.

Users are recommended to upgrade to version 6.4.0 at least and migrate to the new  file upload mechanism https://struts.apache.org/core-developers/file-upload . If you are not using an old file upload logic based on FileuploadInterceptor your application is safe.

You can find more details in  https://cwiki.apache.org/confluence/display/WW/S2-067

Weakness: CWE-434 (Unrestricted Upload of File with Dangerous Type)

## Which versions are affected by CVE-2024-53677?

2 open source packages ship an affected version, including org.apache.struts:struts2-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.struts:struts2-core` | Maven | All versions | 6.4.0 |
| `org.apache.struts:struts2-core` | Maven | All versions | 6.4.0 |

Products: Apache Struts.

## How do I fix CVE-2024-53677?

Upgrade org.apache.struts:struts2-core to 6.4.0 or later.

## Is CVE-2024-53677 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-53677 exists.

Public exploit code:

- A critical vulnerability, CVE-2024-53677, has been identified in the popular Apache Struts framework, potentially allowing attackers to execute arbitrary code remotely. This vulnerability arises from flaws in the file upload logic, which can be exploited to perform path traversal and malicious file uploads. (github_poc): https://github.com/TAM-K592/CVE-2024-53677-S2-067
- File upload logic flaw in Apache Struts2 exploit (github_poc): https://github.com/EQSTLab/CVE-2024-53677
- s2-067(CVE-2024-53677) (github_poc): https://github.com/cloudwafs/s2-067-CVE-2024-53677
- https://github.com/yangyanglo/CVE-2024-53677 (github_poc): https://github.com/yangyanglo/CVE-2024-53677
- A Docker-based environment to reproduce the CVE-2024-53677 vulnerability in Apache Struts 2.  (github_poc): https://github.com/c4oocO/CVE-2024-53677-Docker
- Vulnerable Environment and Exploit for CVE-2024-53677 (github_poc): https://github.com/SeanRickerd/CVE-2024-53677

## Other vulnerabilities in Apache Struts

- [CVE-2020-17530](https://insights.sbomify.com/CVE-2020-17530/): Apache Struts Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2017-9791](https://insights.sbomify.com/CVE-2017-9791/): Apache Struts 1 Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2017-5638](https://insights.sbomify.com/CVE-2017-5638/): Apache Struts Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2012-0391](https://insights.sbomify.com/CVE-2012-0391/): Apache Struts 2 Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2018-11776](https://insights.sbomify.com/CVE-2018-11776/): Apache Struts Remote Code Execution (high 8.1, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-53677 and fix it if it is affected.

What it is: CVE-2024-53677 is a critical vulnerability in Apache Struts, published on 11 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-53677 exists.

Affected packages and fixed versions:
- org.apache.struts:struts2-core (Maven): affected all versions; fixed in 6.4.0
- org.apache.struts:struts2-core (Maven): affected all versions; fixed in 6.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-53677/ (Markdown: https://insights.sbomify.com/CVE-2024-53677/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-53677
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-53677
- OSV: https://osv.dev/vulnerability/CVE-2024-53677

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-53677/
Summaries are generated and may contain mistakes; the official description above is the record.
