CVE-2024-53678 Apache VCL: SQL injection vulnerability in New Block Allocation form

Medium 5.1 Published Updated

Attackers can modify SQL queries in the New Block Allocation form to potentially access data, though returned data is not directly viewable.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2024-53678?

CVE-2024-53678 is a medium-severity SQL injection vulnerability in Apache VCL, published on 25 Mar 2025. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Apache VCL. Users can modify form data submitted when requesting a new Block Allocation such that a SELECT SQL statement is modified. The data returned by the SELECT statement is not viewable by the attacker.

This issue affects all versions of Apache VCL from 2.2 through 2.5.1.

Users are recommended to upgrade to version 2.5.2, which fixes the issue.

Weakness: CWE-89

Which versions are affected by CVE-2024-53678?

It affects 1 product.

Products include Apache Vcl.

How do I fix CVE-2024-53678?

No fix has been published for CVE-2024-53678 yet. Limit exposure of the affected software until one is available.

Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.

Is CVE-2024-53678 being exploited?

There is no known exploitation of CVE-2024-53678 in the wild and no public exploit code.

Sources

Also known as GHSA-fwrx-wppx-25wm.

Is CVE-2024-53678 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free