CVE-2024-53679 Apache VCL: XSS vulnerability in User Lookup impacting user privileges

High 8.4 Published Updated
Exploited in the wild
Not known
Fix
None listed

What is CVE-2024-53679?

CVE-2024-53679 is a high-severity vulnerability in Apache VCL, published on 25 Mar 2025.

Official description

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Apache VCL in the User Lookup form. A user with sufficient rights to be able to view this part of the site can craft a URL or be tricked in to clicking a URL that will give a specified user elevated rights.

This issue affects all versions of Apache VCL through 2.5.1.

Users are recommended to upgrade to version 2.5.2, which fixes the issue.

Weakness: CWE-79

Which versions are affected by CVE-2024-53679?

It affects 1 product.

Products include Apache Vcl.

How do I fix CVE-2024-53679?

No fix has been published for CVE-2024-53679 yet. Limit exposure of the affected software until one is available.

Is CVE-2024-53679 being exploited?

There is no known exploitation of CVE-2024-53679 in the wild and no public exploit code.

Sources

Also known as GHSA-92pj-xr28-j7xr.

Is CVE-2024-53679 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free