# CVE-2024-53679: Apache VCL: XSS vulnerability in User Lookup impacting user privileges


- **Severity:** High 8.4 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/RE:M`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 25 Mar 2025
- **Updated:** 31 Mar 2025
- **Also known as:** GHSA-92pj-xr28-j7xr

## What is CVE-2024-53679?

CVE-2024-53679 is a high-severity vulnerability in Apache VCL, published on 25 Mar 2025. 

### Official description

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Apache VCL in the User Lookup form. A user with sufficient rights to be able to view this part of the site can craft a URL or be tricked in to clicking a URL that will give a specified user elevated rights.

This issue affects all versions of Apache VCL through 2.5.1.

Users are recommended to upgrade to version 2.5.2, which fixes the issue.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-53679?

It affects 1 product.


Products: Apache Vcl.

## How do I fix CVE-2024-53679?

No fix has been published for CVE-2024-53679 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-53679 being exploited?

There is no known exploitation of CVE-2024-53679 in the wild and no public exploit code.

## Other vulnerabilities in Apache VCL

- [CVE-2013-0267](https://insights.sbomify.com/CVE-2013-0267/): Privilege escalation in n/a (high 8.8)
- [CVE-2024-53678](https://insights.sbomify.com/CVE-2024-53678/): Apache VCL: SQL injection vulnerability in New Block Allocation form (medium 5.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-53679 and fix it if it is affected.

What it is: CVE-2024-53679 is a high-severity vulnerability in Apache VCL, published on 25 Mar 2025. 
Exploitation: There is no known exploitation of CVE-2024-53679 in the wild and no public exploit code.

Affected product: Apache VCL. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-53679/ (Markdown: https://insights.sbomify.com/CVE-2024-53679/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-53679
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-53679
- OSV: https://osv.dev/vulnerability/CVE-2024-53679

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-53679/
Summaries are generated and may contain mistakes; the official description above is the record.
