# CVE-2024-53829: Cross-Site Request Forgery in CodeChecker API

> An unauthenticated attacker can hijack a logged-in user's session to modify or delete products in CodeChecker via CSRF.

- **Severity:** High 8.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 21 Jan 2025
- **Updated:** 12 Feb 2025
- **Also known as:** GHSA-f8c8-4pm7-w885, PYSEC-2025-12

## What is CVE-2024-53829?

CVE-2024-53829 is a high-severity vulnerability in Ericsson CodeChecker, published on 21 Jan 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

CodeChecker is an analyzer tooling, defect database and viewer extension for the Clang Static Analyzer and Clang Tidy. 
Cross-site request forgery allows an unauthenticated attacker to hijack the authentication of a logged in user, and use the web API with the same permissions, including but not limited to adding, removing or editing products. The attacker needs to know the ID of the available products to modify or delete them. The attacker cannot directly exfiltrate data (view) from CodeChecker, due to being limited to form-based CSRF.

This issue affects CodeChecker: through 6.24.4.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2024-53829?

3 open source packages ship an affected version, including codechecker. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `codechecker` | PyPI | All versions | 6.24.5 |
| `codechecker` | PyPI | All versions | 6.24.5 |
| `codechecker` | PyPI | All versions | 6.25.0 |

Products: Ericsson Codechecker.

## How do I fix CVE-2024-53829?

Upgrade codechecker to a fixed version for your release line: 6.24.5 or 6.25.0.

## Is CVE-2024-53829 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-53829 exists.

## Other vulnerabilities in Ericsson CodeChecker

- [CVE-2024-10081](https://insights.sbomify.com/CVE-2024-10081/): codechecker vulnerable to authentication bypass when using specifically crafted URLs (critical 10.0)
- [CVE-2026-25660](https://insights.sbomify.com/CVE-2026-25660/): Authentication bypass for certain API calls (critical 9.3)
- [CVE-2024-10082](https://insights.sbomify.com/CVE-2024-10082/): codechecker authentication method confusion vulnerability allows logging in as the built-in root user from an external service (high 8.7)
- [CVE-2023-49793](https://insights.sbomify.com/CVE-2023-49793/): Path traversal in `CodeChecker server` in the endpoint of `CodeChecker store` (medium 6.5)
- [CVE-2025-1300](https://insights.sbomify.com/CVE-2025-1300/): Open redirect in CodeChecker web server (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-53829 and fix it if it is affected.

What it is: CVE-2024-53829 is a high-severity vulnerability in Ericsson CodeChecker, published on 21 Jan 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-53829 exists.

Affected packages and fixed versions:
- codechecker (PyPI): affected all versions; fixed in 6.24.5
- codechecker (PyPI): affected all versions; fixed in 6.24.5
- codechecker (PyPI): affected all versions; fixed in 6.25.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-53829/ (Markdown: https://insights.sbomify.com/CVE-2024-53829/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-53829
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-53829
- OSV: https://osv.dev/vulnerability/CVE-2024-53829

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-53829/
Summaries are generated and may contain mistakes; the official description above is the record.
