{"answers":{"affected":"2 open source packages ship an affected version, including @dapperduckling/keycloak-connector-server.","exploited":"There is no known exploitation of CVE-2024-53843 in the wild and no public exploit code.","fix":"Upgrade @dapperduckling/keycloak-connector-server to 2.5.5 or later.","what":"CVE-2024-53843 is a high-severity cross-site scripting vulnerability in DapperDuckling keycloak-connector, published on 25 Nov 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-53843 and fix it if it is affected.\n\nWhat it is: CVE-2024-53843 is a high-severity cross-site scripting vulnerability in DapperDuckling keycloak-connector, published on 25 Nov 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-53843 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @dapperduckling/keycloak-connector-server (npm): affected all versions; fixed in 2.5.5\n- @dapperduckling/keycloak-connector-server (npm): affected all versions; fixed in 2.5.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-53843/ (Markdown: https://insights.sbomify.com/CVE-2024-53843/index.md)","id":"CVE-2024-53843","markdown":"https://insights.sbomify.com/CVE-2024-53843/index.md","name":"CVE-2024-53843","record":{"aliases":["GHSA-w5rq-g9r6-vrcg"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Keycloak connector library","requires_auth":"none","summary":"Reflected XSS in Keycloak connector allows attackers to execute arbitrary JavaScript via crafted URLs, impacting applications using this library.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"@dapperduckling/keycloak-connector-server is an opinionated series of libraries for Node.js applications and frontend clients to interface with keycloak. A Reflected Cross-Site Scripting (XSS) vulnerability was discovered in the authentication flow of the application. This issue arises due to improper sanitization of the URL parameters, allowing the URL bar's contents to be injected and reflected into the HTML page. An attacker could craft a malicious URL to execute arbitrary JavaScript in the browser of a victim who visits the link. Any application utilizing this authentication library is vulnerable. Users of the application are at risk if they can be lured into clicking on a crafted malicious link. The vulnerability has been patched in version 2.5.5 by ensuring proper sanitization and escaping of user input in the affected URL parameters. Users are strongly encouraged to upgrade. If upgrading is not immediately possible, users can implement the following workarounds: 1. Employ a Web Application Firewall (WAF) to block malicious requests containing suspicious URL parameters. or 2. Apply input validation and escaping directly within the application’s middleware or reverse proxy layer, specifically targeting the affected parameters.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Reflected XSS Vulnerability in Authentication Flow URL Handling in @dapperduckling/keycloak-connector-server","id":"CVE-2024-53843","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2024"},"n_packages":2,"n_references":1,"next":{"headline":"Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in labsai/eddi","id":"CVE-2024-53844"},"packages":[{"ecosystem":"npm","fixed":["2.5.5"],"introduced":["0"],"last_affected":[],"package":"@dapperduckling/keycloak-connector-server","purl":null,"source":"GHSA-w5rq-g9r6-vrcg"},{"ecosystem":"npm","fixed":["2.5.5"],"introduced":["0"],"last_affected":[],"package":"@dapperduckling/keycloak-connector-server","purl":"pkg:npm/%40dapperduckling/keycloak-connector-server","source":"GHSA-w5rq-g9r6-vrcg"}],"prev":{"headline":"Memory corruption in Android","id":"CVE-2024-53842"},"products":["keycloak-connector"],"published":"2024-11-25","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-11-26","vendors":["DapperDuckling"]},"summary":"Reflected XSS in Keycloak connector allows attackers to execute arbitrary JavaScript via crafted URLs, impacting applications using this library.","url":"https://insights.sbomify.com/CVE-2024-53843/"}