# CVE-2024-53843: Reflected XSS Vulnerability in Authentication Flow URL Handling in @dapperduckling/keycloak-connector-server

> Reflected XSS in Keycloak connector allows attackers to execute arbitrary JavaScript via crafted URLs, impacting applications using this library.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 25 Nov 2024
- **Updated:** 26 Nov 2024
- **Also known as:** GHSA-w5rq-g9r6-vrcg

## What is CVE-2024-53843?

CVE-2024-53843 is a high-severity cross-site scripting vulnerability in DapperDuckling keycloak-connector, published on 25 Nov 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

@dapperduckling/keycloak-connector-server is an opinionated series of libraries for Node.js applications and frontend clients to interface with keycloak. A Reflected Cross-Site Scripting (XSS) vulnerability was discovered in the authentication flow of the application. This issue arises due to improper sanitization of the URL parameters, allowing the URL bar's contents to be injected and reflected into the HTML page. An attacker could craft a malicious URL to execute arbitrary JavaScript in the browser of a victim who visits the link. Any application utilizing this authentication library is vulnerable. Users of the application are at risk if they can be lured into clicking on a crafted malicious link. The vulnerability has been patched in version 2.5.5 by ensuring proper sanitization and escaping of user input in the affected URL parameters. Users are strongly encouraged to upgrade. If upgrading is not immediately possible, users can implement the following workarounds: 1. Employ a Web Application Firewall (WAF) to block malicious requests containing suspicious URL parameters. or 2. Apply input validation and escaping directly within the application’s middleware or reverse proxy layer, specifically targeting the affected parameters.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-53843?

2 open source packages ship an affected version, including @dapperduckling/keycloak-connector-server.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@dapperduckling/keycloak-connector-server` | npm | All versions | 2.5.5 |
| `@dapperduckling/keycloak-connector-server` | npm | All versions | 2.5.5 |

## How do I fix CVE-2024-53843?

Upgrade @dapperduckling/keycloak-connector-server to 2.5.5 or later.

## Is CVE-2024-53843 being exploited?

There is no known exploitation of CVE-2024-53843 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-53843 and fix it if it is affected.

What it is: CVE-2024-53843 is a high-severity cross-site scripting vulnerability in DapperDuckling keycloak-connector, published on 25 Nov 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-53843 in the wild and no public exploit code.

Affected packages and fixed versions:
- @dapperduckling/keycloak-connector-server (npm): affected all versions; fixed in 2.5.5
- @dapperduckling/keycloak-connector-server (npm): affected all versions; fixed in 2.5.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-53843/ (Markdown: https://insights.sbomify.com/CVE-2024-53843/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-53843
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-53843
- OSV: https://osv.dev/vulnerability/CVE-2024-53843

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-53843/
Summaries are generated and may contain mistakes; the official description above is the record.
