{"answers":{"affected":"4 open source packages ship an affected version, including trix.","exploited":"There is no known exploitation of CVE-2024-53847 in the wild and no public exploit code.","fix":"Upgrade trix to a fixed version for your release line: 1.3.3 or 2.1.9.","what":"CVE-2024-53847 is a medium-severity cross-site scripting vulnerability in basecamp trix, published on 9 Dec 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-53847 and fix it if it is affected.\n\nWhat it is: CVE-2024-53847 is a medium-severity cross-site scripting vulnerability in basecamp trix, published on 9 Dec 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-53847 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- trix (npm): affected from 1.0.0; fixed in 1.3.3\n- trix (npm): affected from 1.0.0; fixed in 1.3.3\n- trix (npm): affected from 2.0.0; fixed in 2.1.9\n- trix (npm): affected from 2.0.0; fixed in 2.1.9\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-53847/ (Markdown: https://insights.sbomify.com/CVE-2024-53847/index.md)","id":"CVE-2024-53847","markdown":"https://insights.sbomify.com/CVE-2024-53847/index.md","name":"CVE-2024-53847","record":{"aliases":["GHSA-6vx4-v2jw-qwqh"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Trix rich text editor","requires_auth":"none","summary":"An attacker can execute arbitrary JavaScript via malicious copy-paste content in the Trix editor, risking session hijacking or data theft.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":5.1,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N","version":"4.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"The Trix rich text editor, prior to versions 2.1.9 and 1.3.3, is vulnerable to cross-site scripting (XSS) + mutation XSS attacks when pasting malicious code. An attacker could trick a user to copy and paste malicious code that would execute arbitrary JavaScript code within the context of the user's session, potentially leading to unauthorized actions being performed or sensitive information being disclosed. Users should upgrade to Trix editor version 2.1.9 or 1.3.3, which uses DOMPurify to sanitize the pasted content.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Trix vulnerable to Cross-site Scripting on copy \u0026 paste","id":"CVE-2024-53847","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2024"},"n_packages":4,"n_references":2,"next":{"headline":"check-jsonschema default caching for remote schemas allows for cache confusion","id":"CVE-2024-53848"},"packages":[{"ecosystem":"npm","fixed":["1.3.3"],"introduced":["1.0.0"],"last_affected":[],"package":"trix","purl":null,"source":"GHSA-6vx4-v2jw-qwqh"},{"ecosystem":"npm","fixed":["1.3.3"],"introduced":["1.0.0"],"last_affected":[],"package":"trix","purl":"pkg:npm/trix","source":"GHSA-6vx4-v2jw-qwqh"},{"ecosystem":"npm","fixed":["2.1.9"],"introduced":["2.0.0"],"last_affected":[],"package":"trix","purl":null,"source":"GHSA-6vx4-v2jw-qwqh"},{"ecosystem":"npm","fixed":["2.1.9"],"introduced":["2.0.0"],"last_affected":[],"package":"trix","purl":"pkg:npm/trix","source":"GHSA-6vx4-v2jw-qwqh"}],"prev":{"headline":"ssl fails to validate incorrect extened key usage","id":"CVE-2024-53846"},"products":["trix"],"published":"2024-12-09","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-12-10","vendors":["basecamp"]},"summary":"An attacker can execute arbitrary JavaScript via malicious copy-paste content in the Trix editor, risking session hijacking or data theft.","url":"https://insights.sbomify.com/CVE-2024-53847/"}