# CVE-2024-53847: Trix vulnerable to Cross-site Scripting on copy & paste

> An attacker can execute arbitrary JavaScript via malicious copy-paste content in the Trix editor, risking session hijacking or data theft.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 Dec 2024
- **Updated:** 10 Dec 2024
- **Also known as:** GHSA-6vx4-v2jw-qwqh

## What is CVE-2024-53847?

CVE-2024-53847 is a medium-severity cross-site scripting vulnerability in basecamp trix, published on 9 Dec 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

The Trix rich text editor, prior to versions 2.1.9 and 1.3.3, is vulnerable to cross-site scripting (XSS) + mutation XSS attacks when pasting malicious code. An attacker could trick a user to copy and paste malicious code that would execute arbitrary JavaScript code within the context of the user's session, potentially leading to unauthorized actions being performed or sensitive information being disclosed. Users should upgrade to Trix editor version 2.1.9 or 1.3.3, which uses DOMPurify to sanitize the pasted content.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-53847?

4 open source packages ship an affected version, including trix.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `trix` | npm | From 1.0.0 | 1.3.3 |
| `trix` | npm | From 1.0.0 | 1.3.3 |
| `trix` | npm | From 2.0.0 | 2.1.9 |
| `trix` | npm | From 2.0.0 | 2.1.9 |

## How do I fix CVE-2024-53847?

Upgrade trix to a fixed version for your release line: 1.3.3 or 2.1.9.

## Is CVE-2024-53847 being exploited?

There is no known exploitation of CVE-2024-53847 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-53847 and fix it if it is affected.

What it is: CVE-2024-53847 is a medium-severity cross-site scripting vulnerability in basecamp trix, published on 9 Dec 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-53847 in the wild and no public exploit code.

Affected packages and fixed versions:
- trix (npm): affected from 1.0.0; fixed in 1.3.3
- trix (npm): affected from 1.0.0; fixed in 1.3.3
- trix (npm): affected from 2.0.0; fixed in 2.1.9
- trix (npm): affected from 2.0.0; fixed in 2.1.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-53847/ (Markdown: https://insights.sbomify.com/CVE-2024-53847/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-53847
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-53847
- OSV: https://osv.dev/vulnerability/CVE-2024-53847

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-53847/
Summaries are generated and may contain mistakes; the official description above is the record.
