CVE-2024-53856 rPGP Panics on Malformed Untrusted Input

High 7.5 Published Updated

An attacker can cause a denial of service by providing malformed data to the rPGP library, crashing the application.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-53856?

CVE-2024-53856 is a high-severity denial of service vulnerability in rpgp, published on 5 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

rPGP is a pure Rust implementation of OpenPGP. Prior to 0.14.1, rPGP allows an attacker to trigger rpgp crashes by providing crafted data. This vulnerability is fixed in 0.14.1.

Weakness: CWE-617, CWE-148, CWE-130

Which versions are affected by CVE-2024-53856?

3 open source packages ship an affected version, including pgp.

PackageAffectedFixed in
pgp crates.ioAll versions0.14.1
pgp crates.ioAll versions0.14.1
pgp crates.ioFrom 0.0.0-00.14.1

How do I fix CVE-2024-53856?

Upgrade pgp to 0.14.1 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2024-53856 being exploited?

There is no known exploitation of CVE-2024-53856 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2024-53856, GHSA-9rmp-2568-59rv, RUSTSEC-2024-0447.

Is CVE-2024-53856 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free