{"answers":{"affected":"3 open source packages ship an affected version, including pgp.","exploited":"There is no known exploitation of CVE-2024-53856 in the wild and no public exploit code.","fix":"Upgrade pgp to 0.14.1 or later.","what":"CVE-2024-53856 is a high-severity denial of service vulnerability in rpgp, published on 5 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-53856 and fix it if it is affected.\n\nWhat it is: CVE-2024-53856 is a high-severity denial of service vulnerability in rpgp, published on 5 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-53856 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pgp (crates.io): affected all versions; fixed in 0.14.1\n- pgp (crates.io): affected all versions; fixed in 0.14.1\n- pgp (crates.io): affected from 0.0.0-0; fixed in 0.14.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-53856/ (Markdown: https://insights.sbomify.com/CVE-2024-53856/index.md)","id":"CVE-2024-53856","markdown":"https://insights.sbomify.com/CVE-2024-53856/index.md","name":"CVE-2024-53856","record":{"aliases":["DEBIAN-CVE-2024-53856","GHSA-9rmp-2568-59rv","RUSTSEC-2024-0447"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Rust OpenPGP library","requires_auth":"none","summary":"An attacker can cause a denial of service by providing malformed data to the rPGP library, crashing the application.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-617","name":"Reachable Assertion"},{"id":"CWE-148","name":"Improper Neutralization of Input Leaders"},{"id":"CWE-130","name":"Improper Handling of Length Parameter Inconsistency"}],"description":"rPGP is a pure Rust implementation of OpenPGP. Prior to 0.14.1, rPGP allows an attacker to trigger rpgp crashes by providing crafted data. This vulnerability is fixed in 0.14.1.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"rPGP Panics on Malformed Untrusted Input","id":"CVE-2024-53856","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"denial_of_service","year":"2024"},"n_packages":3,"n_references":1,"next":{"headline":"rPGP Potential Resource Exhaustion when handling Untrusted Messages","id":"CVE-2024-53857"},"packages":[{"ecosystem":"crates.io","fixed":["0.14.1"],"introduced":["0"],"last_affected":[],"package":"pgp","purl":null,"source":"GHSA-9rmp-2568-59rv"},{"ecosystem":"crates.io","fixed":["0.14.1"],"introduced":["0"],"last_affected":[],"package":"pgp","purl":"pkg:cargo/pgp","source":"GHSA-9rmp-2568-59rv"},{"ecosystem":"crates.io","fixed":["0.14.1"],"introduced":["0.0.0-0"],"last_affected":[],"package":"pgp","purl":"pkg:cargo/pgp","source":"RUSTSEC-2024-0447"}],"prev":{"headline":"User can view tickets from organizations they're not apart of in centurion_erp","id":"CVE-2024-53855"},"products":["rpgp"],"published":"2024-12-05","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"open","licence":"CC0 1.0","name":"RustSec","prefix":"RUSTSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-12-09","vendors":["rpgp"]},"summary":"An attacker can cause a denial of service by providing malformed data to the rPGP library, crashing the application.","url":"https://insights.sbomify.com/CVE-2024-53856/"}