# CVE-2024-53857: rPGP Potential Resource Exhaustion when handling Untrusted Messages

> Attackers can cause resource exhaustion in the rPGP library by sending crafted messages, leading to denial of service.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Dec 2024
- **Updated:** 5 Dec 2024
- **Also known as:** DEBIAN-CVE-2024-53857, GHSA-4grw-m28r-q285

## What is CVE-2024-53857?

CVE-2024-53857 is a high-severity denial of service vulnerability in rpgp, published on 5 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

rPGP is a pure Rust implementation of OpenPGP. Prior to 0.14.1, rPGP allows attackers to trigger resource exhaustion vulnerabilities in rpgp by providing crafted messages. This affects general message parsing and decryption with symmetric keys.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2024-53857?

2 open source packages ship an affected version, including pgp.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pgp` | crates.io | All versions | 0.14.2 |
| `pgp` | crates.io | All versions | 0.14.2 |

## How do I fix CVE-2024-53857?

Upgrade pgp to 0.14.2 or later.

## Is CVE-2024-53857 being exploited?

There is no known exploitation of CVE-2024-53857 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-53857 and fix it if it is affected.

What it is: CVE-2024-53857 is a high-severity denial of service vulnerability in rpgp, published on 5 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-53857 in the wild and no public exploit code.

Affected packages and fixed versions:
- pgp (crates.io): affected all versions; fixed in 0.14.2
- pgp (crates.io): affected all versions; fixed in 0.14.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-53857/ (Markdown: https://insights.sbomify.com/CVE-2024-53857/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-53857
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-53857
- OSV: https://osv.dev/vulnerability/CVE-2024-53857

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-53857/
Summaries are generated and may contain mistakes; the official description above is the record.
