{"answers":{"affected":"2 open source packages ship an affected version, including spencer14420/sp-php-email-handler.","exploited":"There is no known exploitation of CVE-2024-53860 in the wild and no public exploit code.","fix":"Upgrade spencer14420/sp-php-email-handler to 1.0.0 or later.","what":"CVE-2024-53860 is a high-severity vulnerability in Spencer14420 SPEmailHandler-PHP, published on 27 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-53860 and fix it if it is affected.\n\nWhat it is: CVE-2024-53860 is a high-severity vulnerability in Spencer14420 SPEmailHandler-PHP, published on 27 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-53860 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- spencer14420/sp-php-email-handler (Packagist): affected all versions; fixed in 1.0.0\n- spencer14420/sp-php-email-handler (Packagist): affected all versions; fixed in 1.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-53860/ (Markdown: https://insights.sbomify.com/CVE-2024-53860/index.md)","id":"CVE-2024-53860","markdown":"https://insights.sbomify.com/CVE-2024-53860/index.md","name":"CVE-2024-53860","record":{"aliases":["GHSA-mj5r-x73q-fjw6"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["other"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP email handler","requires_auth":"none","summary":"Attackers can abuse the contact form script to send arbitrary spam or phishing emails, damaging domain reputation and requiring an upgrade to fix.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.6,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-74","name":"Improper Neutralization of Special Elements in Output Used by a Downstream Component"}],"description":"sp-php-email-handler is a PHP package for handling contact form submissions. Messages sent using this script are vulnerable to abuse, as the script allows anybody to specify arbitrary email recipients and include user-provided content in confirmation emails. This could enable malicious actors to use your server to send spam, phishing emails, or other malicious content, potentially damaging your domain's reputation and leading to blacklisting by email providers. Patched in version 1.0.0 by removing user-provided content from confirmation emails. All pre-release versions (alpha and beta) are vulnerable to this issue and should not be used. There are no workarounds for this issue. Users must upgrade to version 1.0.0 to mitigate the vulnerability.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Potential Abuse for Sending Arbitrary Emails in sp-php-email-handler","id":"CVE-2024-53860","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"other","year":"2024"},"n_packages":2,"n_references":2,"next":{"headline":"Issuer field partial matches allowed in pyjwt","id":"CVE-2024-53861"},"packages":[{"ecosystem":"Packagist","fixed":["1.0.0"],"introduced":["0"],"last_affected":[],"package":"spencer14420/sp-php-email-handler","purl":null,"source":"GHSA-mj5r-x73q-fjw6"},{"ecosystem":"Packagist","fixed":["1.0.0"],"introduced":["0"],"last_affected":[],"package":"spencer14420/sp-php-email-handler","purl":"pkg:composer/spencer14420/sp-php-email-handler","source":"GHSA-mj5r-x73q-fjw6"}],"prev":{"headline":"go-gh `auth.TokenForHost` violates GitHub host security boundary within a codespace","id":"CVE-2024-53859"},"products":["SPEmailHandler-PHP"],"published":"2024-11-27","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-12-02","vendors":["Spencer14420"]},"summary":"Attackers can abuse the contact form script to send arbitrary spam or phishing emails, damaging domain reputation and requiring an upgrade to fix.","url":"https://insights.sbomify.com/CVE-2024-53860/"}