# CVE-2024-53860: Potential Abuse for Sending Arbitrary Emails in sp-php-email-handler

> Attackers can abuse the contact form script to send arbitrary spam or phishing emails, damaging domain reputation and requiring an upgrade to fix.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Nov 2024
- **Updated:** 2 Dec 2024
- **Also known as:** GHSA-mj5r-x73q-fjw6

## What is CVE-2024-53860?

CVE-2024-53860 is a high-severity vulnerability in Spencer14420 SPEmailHandler-PHP, published on 27 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

sp-php-email-handler is a PHP package for handling contact form submissions. Messages sent using this script are vulnerable to abuse, as the script allows anybody to specify arbitrary email recipients and include user-provided content in confirmation emails. This could enable malicious actors to use your server to send spam, phishing emails, or other malicious content, potentially damaging your domain's reputation and leading to blacklisting by email providers. Patched in version 1.0.0 by removing user-provided content from confirmation emails. All pre-release versions (alpha and beta) are vulnerable to this issue and should not be used. There are no workarounds for this issue. Users must upgrade to version 1.0.0 to mitigate the vulnerability.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2024-53860?

2 open source packages ship an affected version, including spencer14420/sp-php-email-handler.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `spencer14420/sp-php-email-handler` | Packagist | All versions | 1.0.0 |
| `spencer14420/sp-php-email-handler` | Packagist | All versions | 1.0.0 |

## How do I fix CVE-2024-53860?

Upgrade spencer14420/sp-php-email-handler to 1.0.0 or later.

## Is CVE-2024-53860 being exploited?

There is no known exploitation of CVE-2024-53860 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-53860 and fix it if it is affected.

What it is: CVE-2024-53860 is a high-severity vulnerability in Spencer14420 SPEmailHandler-PHP, published on 27 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-53860 in the wild and no public exploit code.

Affected packages and fixed versions:
- spencer14420/sp-php-email-handler (Packagist): affected all versions; fixed in 1.0.0
- spencer14420/sp-php-email-handler (Packagist): affected all versions; fixed in 1.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-53860/ (Markdown: https://insights.sbomify.com/CVE-2024-53860/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-53860
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-53860
- OSV: https://osv.dev/vulnerability/CVE-2024-53860

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-53860/
Summaries are generated and may contain mistakes; the official description above is the record.
