# CVE-2024-53863: Synapse can be forced to thumbnail unexpected file formats, invoking external, potentially untrustworthy decoders

> Attackers can force thumbnail generation of unsafe formats, potentially invoking vulnerable external decoders to execute code.

- **Severity:** High 8.2 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Dec 2024
- **Updated:** 3 Dec 2024
- **Also known as:** GHSA-vp6v-whfm-rv3g, PYSEC-2026-1615, UBUNTU-CVE-2024-53863

## What is CVE-2024-53863?

CVE-2024-53863 is a high-severity vulnerability in element-hq synapse, published on 3 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Synapse is an open-source Matrix homeserver. In Synapse versions before 1.120.1, enabling the dynamic_thumbnails option or processing a specially crafted request could trigger the decoding and thumbnail generation of uncommon image formats, potentially invoking external tools like Ghostscript for processing. This significantly expands the attack surface in a historically vulnerable area, presenting a risk that far outweighs the benefit, particularly since these formats are rarely used on the open web or within the Matrix ecosystem. Synapse 1.120.1 addresses the issue by restricting thumbnail generation to images in the following widely used formats: PNG, JPEG, GIF, and WebP. This vulnerability is fixed in 1.120.1.

Weakness: CWE-434 (Unrestricted Upload of File with Dangerous Type)

## Which versions are affected by CVE-2024-53863?

3 open source packages ship an affected version, including matrix-synapse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `matrix-synapse` | PyPI | All versions | 1.120.1 |
| `matrix-synapse` | PyPI | All versions | 1.120.1 |
| `matrix-synapse` | PyPI | All versions | 1.120.1 |

Products: Matrix Synapse.

## How do I fix CVE-2024-53863?

Upgrade matrix-synapse to 1.120.1 or later.

## Is CVE-2024-53863 being exploited?

There is no known exploitation of CVE-2024-53863 in the wild and no public exploit code.

## Other vulnerabilities in element-hq synapse

- [CVE-2019-18835](https://insights.sbomify.com/CVE-2019-18835/): Improper Verification of Cryptographic Signature in matrix-synapse (critical 9.8)
- [CVE-2024-52815](https://insights.sbomify.com/CVE-2024-52815/): Synapse allows a a malformed invite to break the invitee's `/sync` (high 8.7)
- [CVE-2024-52805](https://insights.sbomify.com/CVE-2024-52805/): Synapse allows unsupported content types to lead to memory exhaustion (high 8.2)
- [CVE-2024-37302](https://insights.sbomify.com/CVE-2024-37302/): Synapse denial of service through media disk space consumption (high 7.5)
- [CVE-2018-12423](https://insights.sbomify.com/CVE-2018-12423/): Matrix Synapse Authorization Error (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-53863 and fix it if it is affected.

What it is: CVE-2024-53863 is a high-severity vulnerability in element-hq synapse, published on 3 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-53863 in the wild and no public exploit code.

Affected packages and fixed versions:
- matrix-synapse (PyPI): affected all versions; fixed in 1.120.1
- matrix-synapse (PyPI): affected all versions; fixed in 1.120.1
- matrix-synapse (PyPI): affected all versions; fixed in 1.120.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-53863/ (Markdown: https://insights.sbomify.com/CVE-2024-53863/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-53863
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-53863
- OSV: https://osv.dev/vulnerability/CVE-2024-53863

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-53863/
Summaries are generated and may contain mistakes; the official description above is the record.
