{"answers":{"affected":"2 open source packages ship an affected version, including ibexa/admin-ui.","exploited":"There is no known exploitation of CVE-2024-53864 in the wild and no public exploit code.","fix":"Upgrade ibexa/admin-ui to 4.6.14 or later.","what":"CVE-2024-53864 is a medium-severity cross-site scripting vulnerability in ibexa admin-ui, published on 29 Nov 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-53864 and fix it if it is affected.\n\nWhat it is: CVE-2024-53864 is a medium-severity cross-site scripting vulnerability in ibexa admin-ui, published on 29 Nov 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-53864 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ibexa/admin-ui (Packagist): affected from 4.6.0; fixed in 4.6.14\n- ibexa/admin-ui (Packagist): affected from 4.6.0; fixed in 4.6.14\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-53864/ (Markdown: https://insights.sbomify.com/CVE-2024-53864/index.md)","id":"CVE-2024-53864","markdown":"https://insights.sbomify.com/CVE-2024-53864/index.md","name":"CVE-2024-53864","record":{"aliases":["GHSA-8w3p-gf85-qcch"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Ibexa Admin UI","requires_auth":"none","summary":"Attackers with content edit permissions can inject malicious scripts via the Content name pattern field in Ibexa Admin UI, potentially leading to session hijacking or code execution.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Ibexa Admin UI Bundle is all the necessary parts to run the Ibexa DXP Back Office interface. The Content name pattern is used to build Content names from one or more fields. An XSS vulnerability has been found in this mechanism. Content edit permission is required to exploit it. After the fix, any existing injected XSS will not run. This issue has been patched in version 4.6.14. All users are advised to upgrade. There are no known workarounds for this vulnerability.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-site Scripting in a field that is used in the Content name pattern in ibexa/admin-ui","id":"CVE-2024-53864","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2024"},"n_packages":2,"n_references":4,"next":{"headline":"Python package \"zhmcclient\" has passwords in clear text in its HMC and API logs","id":"CVE-2024-53865"},"packages":[{"ecosystem":"Packagist","fixed":["4.6.14"],"introduced":["4.6.0"],"last_affected":[],"package":"ibexa/admin-ui","purl":null,"source":"GHSA-8w3p-gf85-qcch"},{"ecosystem":"Packagist","fixed":["4.6.14"],"introduced":["4.6.0"],"last_affected":[],"package":"ibexa/admin-ui","purl":"pkg:composer/ibexa/admin-ui","source":"GHSA-8w3p-gf85-qcch"}],"prev":{"headline":"Synapse can be forced to thumbnail unexpected file formats, invoking external, potentially untrustworthy decoders","id":"CVE-2024-53863"},"products":["admin-ui"],"published":"2024-11-29","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-12-02","vendors":["ibexa"]},"summary":"Attackers with content edit permissions can inject malicious scripts via the Content name pattern field in Ibexa Admin UI, potentially leading to session hijacking or code execution.","url":"https://insights.sbomify.com/CVE-2024-53864/"}